summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-20 02:58:05 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-20 02:58:05 +0000
commitd5d9da992359517f3089f9c57afdf184bbbefff2 (patch)
tree018ddfdc3a00a11def889c1f6729575a31812a58 /app-sci
parentmasked off packages that depend on baselayout-1.8.0 (diff)
downloadgentoo-2-d5d9da992359517f3089f9c57afdf184bbbefff2.tar.gz
gentoo-2-d5d9da992359517f3089f9c57afdf184bbbefff2.tar.bz2
gentoo-2-d5d9da992359517f3089f9c57afdf184bbbefff2.zip
new package pymol: molecular visualisaion tool
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/pymol/ChangeLog12
-rw-r--r--app-sci/pymol/files/digest-pymol-0.821
-rw-r--r--app-sci/pymol/files/pymol-gentoo.diff53
-rw-r--r--app-sci/pymol/pymol-0.82.ebuild56
4 files changed, 122 insertions, 0 deletions
diff --git a/app-sci/pymol/ChangeLog b/app-sci/pymol/ChangeLog
new file mode 100644
index 000000000000..fc1af19822d5
--- /dev/null
+++ b/app-sci/pymol/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-sci/pymol
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/ChangeLog,v 1.1 2002/07/20 02:58:05 george Exp $
+
+*pymol-0.82.ebuild (17 July 2002)
+
+ 17 July 2002; George Shapovalov <george@gentoo.org> pymol-0.82.ebuild, files/digest-pymol-0.82, ChangeLog :
+
+ Inital release,
+ molecular visualization package
+
+ ebuild submitted by Ben Cornett <acornet@emory.edu>
diff --git a/app-sci/pymol/files/digest-pymol-0.82 b/app-sci/pymol/files/digest-pymol-0.82
new file mode 100644
index 000000000000..3104b5547987
--- /dev/null
+++ b/app-sci/pymol/files/digest-pymol-0.82
@@ -0,0 +1 @@
+MD5 d01bf39dbaa3ada27809a0ba013a162a pymol-0_82-src.tgz 1515449
diff --git a/app-sci/pymol/files/pymol-gentoo.diff b/app-sci/pymol/files/pymol-gentoo.diff
new file mode 100644
index 000000000000..8b4b2baabd4b
--- /dev/null
+++ b/app-sci/pymol/files/pymol-gentoo.diff
@@ -0,0 +1,53 @@
+--- Rules.linux Sun Mar 31 03:06:22 2002
++++ Rules.make Tue May 21 15:42:31 2002
+@@ -12,14 +12,13 @@
+ XLIB_DIR = -L/usr/X11R6/lib
+ XINC_DIR = -I/usr/X11R6/include
+ #--- Python
+-PYTHON_EXE = $(PYMOL_PATH)/ext/bin/python
++PYTHON_EXE = /usr/bin/python
+ PYTHON_LIB =
+ PYTHON_LIB_DIR =
+-PYTHON_INC_DIR = -I$(PYMOL_PATH)/ext/include/python2.1 \
+- -I$(PYMOL_PATH)/ext/include/python2.1/Numeric
++PYTHON_INC_DIR = -I/usr/include/python2.2 -I/usr/include/python2.2/Numeric
+ #--- Other external dependencies
+-EXT_INC_DIR = -I$(PYMOL_PATH)/ext/include
+-EXT_LIB_DIR = -L$(PYMOL_PATH)/ext/lib
++EXT_INC_DIR =
++EXT_LIB_DIR =
+ #---------------------------------------------------------------------
+ #
+ #- Build for LINUX as an importable module ---------------------------
+@@ -48,7 +47,7 @@
+ #
+ #- Choose One --------------------------------------------------------
+ #--- Workaround for XFree86/DRI linux dll problem for module build
+-BUGS = -D_DRI_WORKAROUND
++DEFS += -D_DRI_WORKAROUND
+ #---
+ #BUGS =
+ #---------------------------------------------------------------------
+@@ -58,7 +57,7 @@
+ #PNG = -D_HAVE_LIBPNG
+ #ZLIB =
+ #--- Libpng2 available but needs zlib
+-PNG = -D_HAVE_LIBPNG
++DEFS += -D_HAVE_LIBPNG
+ ZLIB = -lz
+ #--- Libpng2 not available
+ #PNG =
+@@ -77,12 +76,7 @@
+ PYMOL_INC_DIRS = -I../layer0 -I../layer1 -I../layer2 \
+ -I../layer3 -I../layer4 -I../layer5
+
+-C_FLAGS = $(CCOPT1) $(CCOPT2) $(EXT_INC_DIR) $(PYTHON_INC_DIR) \
+- $(XINC_DIR) $(PNG) $(DEFS) $(BUGS)
+-
+-CFLAGS = $(C_FLAGS)
+-
+-
++C_FLAGS := $(CFLAGS) $(PYTHON_INC_DIR) $(XINC_DIR) $(DEFS)
+
+
+
diff --git a/app-sci/pymol/pymol-0.82.ebuild b/app-sci/pymol/pymol-0.82.ebuild
new file mode 100644
index 000000000000..d423435ec86f
--- /dev/null
+++ b/app-sci/pymol/pymol-0.82.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pymol/pymol-0.82.ebuild,v 1.1 2002/07/20 02:58:05 george Exp $
+
+A="pymol-0_82-src.tgz"
+S="$WORKDIR/${P}"
+DESCRIPTION="A Python-extensible molecular graphics system."
+SRC_URI="http://download.sourceforge.net/pymol/${A}"
+HOMEPAGE="http://pymol.sf.net"
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-lang/python
+ dev-python/pmw
+ dev-python/Numeric
+ dev-lang/tk
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/glut
+ "
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp setup/Rules.linux Rules.make
+ patch -p0 < ${FILESDIR}/${PN}-gentoo.diff || die
+}
+
+src_compile() {
+ CFLAGS="$CFLAGS -ffast-math -funroll-loops"
+ make || die
+}
+
+
+src_install()
+{
+ local PYMOL_PATH=/usr/lib/pymol/${PV}
+ mkdir -p ${D}/usr/lib/pymol/${PV}
+ cp -a modules ${D}/usr/lib/pymol/${PV}
+ mkdir -p ${D}/usr/bin
+ cat <<-EOF > ${D}/usr/bin/pymol-${PV}
+ #!/bin/sh
+ export PYMOL_PATH=/usr/lib/pymol/${PV}
+ export TCL_LIBRARY=/usr/lib/tcl8.3
+ export PYTHONPATH=/usr/lib/pymol/${PV/modules}:\${PYTHONPATH}
+ python /usr/lib/pymol/${PV}/modules/launch_pymol.py \$*
+ EOF
+ chmod 755 ${D}/usr/bin/pymol-${PV}
+ dodoc README DEVELOPERS CHANGES
+ cd ${D}/usr/bin
+ ln -fs pymol-${PV} pymol
+}
+
+