summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-01 20:38:04 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-01 20:38:04 +0000
commit5a7ff17c93917c378ac178c8b2013b6dfcc60c0a (patch)
treed0bf321a078645b1f9eb74ea05b3f940240619bd /app-shells/bash/files
parentunmask cppserv, as it can now work with apache-2.2 (diff)
downloadgentoo-2-5a7ff17c93917c378ac178c8b2013b6dfcc60c0a.tar.gz
gentoo-2-5a7ff17c93917c378ac178c8b2013b6dfcc60c0a.tar.bz2
gentoo-2-5a7ff17c93917c378ac178c8b2013b6dfcc60c0a.zip
Fix from Takashi YOSHII to respect LDFLAGS_FOR_BUILD #211947.
(Portage version: 2.2_pre2)
Diffstat (limited to 'app-shells/bash/files')
-rw-r--r--app-shells/bash/files/bash-3.2-ldflags-for-build.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/bash/files/bash-3.2-ldflags-for-build.patch b/app-shells/bash/files/bash-3.2-ldflags-for-build.patch
new file mode 100644
index 000000000000..2dc1dd6ef790
--- /dev/null
+++ b/app-shells/bash/files/bash-3.2-ldflags-for-build.patch
@@ -0,0 +1,37 @@
+http://bugs.gentoo.org/211947
+
+fix from Takashi YOSHII: dont use target ldflags for build apps
+
+--- bash/builtins/Makefile.in
++++ bash/builtins/Makefile.in
+@@ -63,7 +63,7 @@
+
+ LIBS = @LIBS@
+ LDFLAGS = @LDFLAGS@ $(LOCAL_LDFLAGS) $(CFLAGS)
+-LDFLAGS_FOR_BUILD = $(LDFLAGS)
++LDFLAGS_FOR_BUILD = @LDFLAGS_FOR_BUILD@ $(LOCAL_LDFLAGS) $(CFLAGS_FOR_BUILD)
+ LOCAL_LDFLAGS = @LOCAL_LDFLAGS@
+ #LIBS_FOR_BUILD = @LIBS_FOR_BUILD@
+ LIBS_FOR_BUILD = $(LIBS)
+--- bash/support/Makefile.in
++++ bash/support/Makefile.in
+@@ -58,7 +58,7 @@
+
+ LOCAL_LDFLAGS = @LOCAL_LDFLAGS@
+ LDFLAGS = @LDFLAGS@ $(LOCAL_LDFLAGS) $(CFLAGS)
+-LDFLAGS_FOR_BUILD = $(LDFLAGS)
++LDFLAGS_FOR_BUILD = @LDFLAGS_FOR_BUILD@ $(LOCAL_LDFLAGS) $(CFLAGS_FOR_BUILD)
+
+ INCLUDES = -I${BUILD_DIR} -I${topdir}
+
+--- bash/Makefile.in
++++ bash/Makefile.in
+@@ -143,7 +143,7 @@
+ CCFLAGS_FOR_BUILD = $(BASE_CCFLAGS) $(CPPFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD)
+
+ LDFLAGS = @LDFLAGS@ $(STATIC_LD) $(LOCAL_LDFLAGS) $(PROFILE_FLAGS) $(CFLAGS)
+-LDFLAGS_FOR_BUILD = $(LDFLAGS)
++LDFLAGS_FOR_BUILD = @LDFLAGS_FOR_BUILD@ $(LOCAL_LDFLAGS) $(CFLAGS_FOR_BUILD)
+
+ INCLUDES = -I. @RL_INCLUDE@ -I$(srcdir) -I$(BASHINCDIR) -I$(LIBSRC) $(INTL_INC)
+