summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-07-16 19:18:18 +0000
committerTim Harder <radhermit@gentoo.org>2013-07-16 19:18:18 +0000
commit101d6f0485deba94fcff33ec25469786a5fc7305 (patch)
tree550a0aee820e8202ff6487111db131c85bace852 /app-shells
parentRevert to using a system zprofile instead of zshenv and add info for new user... (diff)
downloadgentoo-2-101d6f0485deba94fcff33ec25469786a5fc7305.tar.gz
gentoo-2-101d6f0485deba94fcff33ec25469786a5fc7305.tar.bz2
gentoo-2-101d6f0485deba94fcff33ec25469786a5fc7305.zip
Remove old.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/ChangeLog7
-rw-r--r--app-shells/zsh/files/zshenv-142
-rw-r--r--app-shells/zsh/zsh-4.3.17.ebuild181
-rw-r--r--app-shells/zsh/zsh-5.0.0.ebuild181
-rw-r--r--app-shells/zsh/zsh-5.0.2-r1.ebuild183
-rw-r--r--app-shells/zsh/zsh-5.0.2-r2.ebuild183
6 files changed, 6 insertions, 771 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index d21f72b99855..ed4d60850d29 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/zsh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.215 2013/07/16 19:16:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.216 2013/07/16 19:18:18 radhermit Exp $
+
+ 16 Jul 2013; Tim Harder <radhermit@gentoo.org> -zsh-4.3.17.ebuild,
+ -zsh-5.0.0.ebuild, -zsh-5.0.2-r1.ebuild, -zsh-5.0.2-r2.ebuild,
+ -files/zshenv-1:
+ Remove old.
*zsh-5.0.2-r3 (16 Jul 2013)
diff --git a/app-shells/zsh/files/zshenv-1 b/app-shells/zsh/files/zshenv-1
deleted file mode 100644
index 8bafafeed859..000000000000
--- a/app-shells/zsh/files/zshenv-1
+++ /dev/null
@@ -1,42 +0,0 @@
-# @GENTOO_PORTAGE_EPREFIX@/etc/zsh/zshenv
-
-# Load environment settings from profile.env, which is created by
-# env-update from the files in /etc/env.d
-if [ -e "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env ] ; then
- . "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env
-fi
-
-# You should override these in your ~/.zprofile (or equivalent) for per-user
-# settings. For system defaults, you can add a new file in /etc/profile.d/.
-export EDITOR=${EDITOR:-/bin/nano}
-export PAGER=${PAGER:-/usr/bin/less}
-
-# 077 would be more secure, but 022 is generally quite realistic
-umask 022
-
-# Set up PATH depending on whether we're root or a normal user.
-# There's no real reason to exclude sbin paths from the normal user,
-# but it can make tab-completion easier when they aren't in the
-# user's PATH to pollute the executable namespace.
-#
-# It is intentional in the following line to use || instead of -o.
-# This way the evaluation can be short-circuited and calling whoami is
-# avoided.
-if [ "$EUID" = "0" ] || [ "$USER" = "root" ] ; then
- @ZSH_NOPREFIX@PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:${ROOTPATH}"
- @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/sbin:@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/sbin:@GENTOO_PORTAGE_EPREFIX@/bin:${ROOTPATH}:/usr/sbin:/usr/bin:/sbin:/bin"
-else
- @ZSH_NOPREFIX@PATH="/usr/local/bin:/usr/bin:/bin:${PATH}"
- @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/bin:${PATH}:/usr/bin:/bin"
-fi
-export PATH
-unset ROOTPATH
-
-shopts=$-
-setopt nullglob
-for sh in "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.d/*.sh ; do
- [ -r "$sh" ] && . "$sh"
-done
-unsetopt nullglob
-set -$shopts
-unset sh shopts
diff --git a/app-shells/zsh/zsh-4.3.17.ebuild b/app-shells/zsh/zsh-4.3.17.ebuild
deleted file mode 100644
index 7a8a0123a345..000000000000
--- a/app-shells/zsh/zsh-4.3.17.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.17.ebuild,v 1.9 2012/12/08 12:35:59 ago Exp $
-
-EAPI=4
-
-# doc package for -dev version exists?
-doc_available=true
-
-inherit eutils flag-o-matic multilib prefix
-
-MY_PV=${PV/_p/-dev-}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-zsh_ftp="ftp://ftp.zsh.org/pub"
-
-if [[ ${PV} != "${MY_PV}" ]] ; then
- ZSH_URI="${zsh_ftp}/development/${PN}-${MY_PV}.tar.bz2"
- if ${doc_available} ; then
- ZSH_DOC_URI="${zsh_ftp}/development/${PN}-${MY_PV}-doc.tar.bz2"
- else
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
- fi
-else
- ZSH_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- ${zsh_ftp}/${P}.tar.bz2"
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="${ZSH_URI}
- doc? ( ${ZSH_DOC_URI} )"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1
- static? ( >=sys-libs/ncurses-5.7-r4[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? ( >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] ) )
- gdbm? ( sys-libs/gdbm )
-"
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-
-src_prepare() {
- # fix zshall problem with soelim
- ln -s Doc man1
- mv Doc/zshall.1 Doc/zshall.1.soelim
- soelim Doc/zshall.1.soelim > Doc/zshall.1
-
- epatch "${FILESDIR}/${PN}"-init.d-gentoo-r1.diff
-
- cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
- eprefixify "${T}"/zprofile || die
- if use prefix ; then
- sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
- else
- sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
- fi
-}
-
-src_configure() {
- local myconf=
-
- if use static ; then
- myconf+=" --disable-dynamic"
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=" \
- --enable-zsh-debug \
- --enable-zsh-mem-debug \
- --enable-zsh-mem-warning \
- --enable-zsh-secure-free \
- --enable-zsh-hash-debug"
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=" --enable-libs=-liconv"
- append-ldflags -Wl,-x
- fi
-
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-term-lib="ncursesw ncurses" \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- ${myconf}
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -i \
- -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
-# else
-# sed -i -e "/LIBS/s%-lpcre%${EPREFIX}/usr/$(get_libdir)/libpcre.a%" Makefile
- fi
-}
-
-src_test() {
- local i
- addpredict /dev/ptmx
- for i in C02cond.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install install.info
-
- insinto /etc/zsh
- doins "${T}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- # install miscellaneous scripts; bug #54520
- local i
- sed -i -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" "${S}"/{Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/${PV%_*}/${i}
- doins ${i}/*
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dohtml -r Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
- # should link to http://www.gentoo.org/doc/en/zsh.xml
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
-}
diff --git a/app-shells/zsh/zsh-5.0.0.ebuild b/app-shells/zsh/zsh-5.0.0.ebuild
deleted file mode 100644
index 0969c276ee30..000000000000
--- a/app-shells/zsh/zsh-5.0.0.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-5.0.0.ebuild,v 1.1 2012/07/22 01:34:03 radhermit Exp $
-
-EAPI=4
-
-# doc package for -dev version exists?
-doc_available=true
-
-inherit eutils flag-o-matic multilib prefix
-
-MY_PV=${PV/_p/-dev-}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-zsh_ftp="ftp://ftp.zsh.org/pub"
-
-if [[ ${PV} != "${MY_PV}" ]] ; then
- ZSH_URI="${zsh_ftp}/development/${PN}-${MY_PV}.tar.bz2"
- if ${doc_available} ; then
- ZSH_DOC_URI="${zsh_ftp}/development/${PN}-${MY_PV}-doc.tar.bz2"
- else
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
- fi
-else
- ZSH_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- ${zsh_ftp}/${P}.tar.bz2"
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="${ZSH_URI}
- doc? ( ${ZSH_DOC_URI} )"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1
- static? ( >=sys-libs/ncurses-5.7-r4[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? ( >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] ) )
- gdbm? ( sys-libs/gdbm )
-"
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-
-src_prepare() {
- # fix zshall problem with soelim
- ln -s Doc man1
- mv Doc/zshall.1 Doc/zshall.1.soelim
- soelim Doc/zshall.1.soelim > Doc/zshall.1
-
- epatch "${FILESDIR}/${PN}"-init.d-gentoo-r1.diff
-
- cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
- eprefixify "${T}"/zprofile || die
- if use prefix ; then
- sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
- else
- sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
- fi
-}
-
-src_configure() {
- local myconf=
-
- if use static ; then
- myconf+=" --disable-dynamic"
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=" \
- --enable-zsh-debug \
- --enable-zsh-mem-debug \
- --enable-zsh-mem-warning \
- --enable-zsh-secure-free \
- --enable-zsh-hash-debug"
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=" --enable-libs=-liconv"
- append-ldflags -Wl,-x
- fi
-
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-term-lib="ncursesw ncurses" \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- ${myconf}
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -i \
- -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
-# else
-# sed -i -e "/LIBS/s%-lpcre%${EPREFIX}/usr/$(get_libdir)/libpcre.a%" Makefile
- fi
-}
-
-src_test() {
- local i
- addpredict /dev/ptmx
- for i in C02cond.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install install.info
-
- insinto /etc/zsh
- doins "${T}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- # install miscellaneous scripts; bug #54520
- local i
- sed -i -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" "${S}"/{Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/${PV%_*}/${i}
- doins ${i}/*
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dohtml -r Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
- # should link to http://www.gentoo.org/doc/en/zsh.xml
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
-}
diff --git a/app-shells/zsh/zsh-5.0.2-r1.ebuild b/app-shells/zsh/zsh-5.0.2-r1.ebuild
deleted file mode 100644
index ab0fa92091c0..000000000000
--- a/app-shells/zsh/zsh-5.0.2-r1.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-5.0.2-r1.ebuild,v 1.2 2013/05/29 10:26:09 radhermit Exp $
-
-EAPI=5
-
-# doc package for -dev version exists?
-doc_available=true
-
-inherit eutils flag-o-matic multilib prefix
-
-MY_PV=${PV/_p/-dev-}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-zsh_ftp="ftp://ftp.zsh.org/pub"
-
-if [[ ${PV} != "${MY_PV}" ]] ; then
- ZSH_URI="${zsh_ftp}/development/${PN}-${MY_PV}.tar.bz2"
- if ${doc_available} ; then
- ZSH_DOC_URI="${zsh_ftp}/development/${PN}-${MY_PV}-doc.tar.bz2"
- else
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
- fi
-else
- ZSH_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- ${zsh_ftp}/${P}.tar.bz2"
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="${ZSH_URI}
- doc? ( ${ZSH_DOC_URI} )"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1
- static? ( >=sys-libs/ncurses-5.7-r4[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? ( >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] ) )
- gdbm? ( sys-libs/gdbm )
-"
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-
-src_prepare() {
- # fix zshall problem with soelim
- ln -s Doc man1
- mv Doc/zshall.1 Doc/zshall.1.soelim
- soelim Doc/zshall.1.soelim > Doc/zshall.1
-
- epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
- epatch "${FILESDIR}"/${PN}-fix-parameter-modifier-crash.patch
- epatch "${FILESDIR}"/${PN}-5.0.2-texinfo-5.1.patch
-
- cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
- eprefixify "${T}"/zprofile || die
- if use prefix ; then
- sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
- else
- sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
- fi
-}
-
-src_configure() {
- local myconf=
-
- if use static ; then
- myconf+=" --disable-dynamic"
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=" \
- --enable-zsh-debug \
- --enable-zsh-mem-debug \
- --enable-zsh-mem-warning \
- --enable-zsh-secure-free \
- --enable-zsh-hash-debug"
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=" --enable-libs=-liconv"
- append-ldflags -Wl,-x
- fi
-
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-term-lib="ncursesw ncurses" \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- ${myconf}
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -i \
- -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
- fi
-}
-
-src_test() {
- local i
- addpredict /dev/ptmx
- for i in C02cond.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install install.info
-
- insinto /etc/zsh
- doins "${T}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- # install miscellaneous scripts; bug #54520
- local i
- sed -i -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" "${S}"/{Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/${PV%_*}/${i}
- doins ${i}/*
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dohtml -r Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # should link to http://www.gentoo.org/doc/en/zsh.xml
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- fi
-}
diff --git a/app-shells/zsh/zsh-5.0.2-r2.ebuild b/app-shells/zsh/zsh-5.0.2-r2.ebuild
deleted file mode 100644
index 23612108a5ff..000000000000
--- a/app-shells/zsh/zsh-5.0.2-r2.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-5.0.2-r2.ebuild,v 1.1 2013/06/25 19:00:29 radhermit Exp $
-
-EAPI=5
-
-# doc package for -dev version exists?
-doc_available=true
-
-inherit eutils flag-o-matic multilib prefix
-
-MY_PV=${PV/_p/-dev-}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-zsh_ftp="ftp://ftp.zsh.org/pub"
-
-if [[ ${PV} != "${MY_PV}" ]] ; then
- ZSH_URI="${zsh_ftp}/development/${PN}-${MY_PV}.tar.bz2"
- if ${doc_available} ; then
- ZSH_DOC_URI="${zsh_ftp}/development/${PN}-${MY_PV}-doc.tar.bz2"
- else
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
- fi
-else
- ZSH_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- ${zsh_ftp}/${P}.tar.bz2"
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="${ZSH_URI}
- doc? ( ${ZSH_DOC_URI} )"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1
- static? ( >=sys-libs/ncurses-5.7-r4[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? ( >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] ) )
- gdbm? ( sys-libs/gdbm )
-"
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-
-src_prepare() {
- # fix zshall problem with soelim
- ln -s Doc man1
- mv Doc/zshall.1 Doc/zshall.1.soelim
- soelim Doc/zshall.1.soelim > Doc/zshall.1
-
- epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
- epatch "${FILESDIR}"/${PN}-fix-parameter-modifier-crash.patch
- epatch "${FILESDIR}"/${PN}-5.0.2-texinfo-5.1.patch
-
- cp "${FILESDIR}"/zshenv-1 "${T}"/zshenv || die
- eprefixify "${T}"/zshenv || die
- if use prefix ; then
- sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zshenv || die
- else
- sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zshenv || die
- fi
-}
-
-src_configure() {
- local myconf=
-
- if use static ; then
- myconf+=" --disable-dynamic"
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=" \
- --enable-zsh-debug \
- --enable-zsh-mem-debug \
- --enable-zsh-mem-warning \
- --enable-zsh-secure-free \
- --enable-zsh-hash-debug"
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=" --enable-libs=-liconv"
- append-ldflags -Wl,-x
- fi
-
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-term-lib="ncursesw ncurses" \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- ${myconf}
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -i \
- -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
- fi
-}
-
-src_test() {
- local i
- addpredict /dev/ptmx
- for i in C02cond.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install install.info
-
- insinto /etc/zsh
- doins "${T}"/zshenv
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- # install miscellaneous scripts; bug #54520
- local i
- sed -i -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" "${S}"/{Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/${PV%_*}/${i}
- doins ${i}/*
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dohtml -r Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # should link to http://www.gentoo.org/doc/en/zsh.xml
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- fi
-}