summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-07-28 16:15:09 +0000
committerMike Frysinger <vapier@gentoo.org>2015-07-28 16:15:09 +0000
commit76c7cf6cefe05d7779e77596910b2f4698115d59 (patch)
treef2a2093d598db3a3fee0bdfa6c6c67ee09b03d3b /app-shells
parentVersion bump (diff)
downloadgentoo-2-76c7cf6cefe05d7779e77596910b2f4698115d59.tar.gz
gentoo-2-76c7cf6cefe05d7779e77596910b2f4698115d59.tar.bz2
gentoo-2-76c7cf6cefe05d7779e77596910b2f4698115d59.zip
Update echo docs in man page to match change in behavior.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog6
-rw-r--r--app-shells/dash/files/dash-0.5.8.1-dumb-echo.patch51
2 files changed, 56 insertions, 1 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 62a1e9272454..3c50f669482e 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.136 2015/07/23 20:44:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.137 2015/07/28 16:15:09 vapier Exp $
+
+ 28 Jul 2015; Mike Frysinger <vapier@gentoo.org>
+ files/dash-0.5.8.1-dumb-echo.patch:
+ Update echo docs in man page to match change in behavior.
23 Jul 2015; Pacho Ramos <pacho@gentoo.org> dash-0.5.8.2.ebuild:
ppc stable wrt bug #552144
diff --git a/app-shells/dash/files/dash-0.5.8.1-dumb-echo.patch b/app-shells/dash/files/dash-0.5.8.1-dumb-echo.patch
index e8a37d667b9a..4059a80e3301 100644
--- a/app-shells/dash/files/dash-0.5.8.1-dumb-echo.patch
+++ b/app-shells/dash/files/dash-0.5.8.1-dumb-echo.patch
@@ -52,3 +52,54 @@ sequence. it also makes dash smaller & faster to disable this logic entirely.
+ outc('\n', out1);
return 0;
}
+--- a/src/dash.1
++++ b/src/dash.1
+@@ -1180,43 +1180,15 @@
+ option turns off the effect of any preceding
+ .Fl P
+ options.
+-.It Xo echo Op Fl n
++.It Xo echo
+ .Ar args...
+ .Xc
+ Print the arguments on the standard output, separated by spaces.
+-Unless the
+-.Fl n
+-option is present, a newline is output following the arguments.
+-.Pp
+-If any of the following sequences of characters is encountered during
+-output, the sequence is not output. Instead, the specified action is
+-performed:
+-.Bl -tag -width indent
+-.It Li \eb
+-A backspace character is output.
+-.It Li \ec
+-Subsequent output is suppressed. This is normally used at the end of the
+-last argument to suppress the trailing newline that
+-.Ic echo
+-would otherwise output.
+-.It Li \ef
+-Output a form feed.
+-.It Li \en
+-Output a newline character.
+-.It Li \er
+-Output a carriage return.
+-.It Li \et
+-Output a (horizontal) tab character.
+-.It Li \ev
+-Output a vertical tab.
+-.It Li \e0 Ns Ar digits
+-Output the character whose value is given by zero to three octal digits.
+-If there are zero digits, a nul character is output.
+-.It Li \e\e
+-Output a backslash.
+-.El
+ .Pp
+-All other backslash sequences elicit undefined behaviour.
++No arguments or backslash sequences are supported as they are not portable.
++They will be printed out exactly as passed in.
++.Pp
++You can replace `echo -n ...` with the portable `printf %s ...` construct.
+ .It eval Ar string ...
+ Concatenate all the arguments with spaces.
+ Then re-parse and execute the command.