summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-08-06 22:02:54 +0000
committerMichael Weber <xmw@gentoo.org>2013-08-06 22:02:54 +0000
commit7e4d58259f42d6309d18e258c0b28a6e841d18f5 (patch)
tree811ad7b7b711c8131917899231d6232acc711c09 /app-shells
parentUpdate the gentoo-install.patch to match current git. (diff)
downloadgentoo-2-7e4d58259f42d6309d18e258c0b28a6e841d18f5.tar.gz
gentoo-2-7e4d58259f42d6309d18e258c0b28a6e841d18f5.tar.bz2
gentoo-2-7e4d58259f42d6309d18e258c0b28a6e841d18f5.zip
Fix EPREFIX handling (thanks Leho Kraav, bug 465226), version bump.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/autojump/ChangeLog10
-rw-r--r--app-shells/autojump/autojump-21.5.8-r1.ebuild59
-rw-r--r--app-shells/autojump/autojump-21.6.9.ebuild (renamed from app-shells/autojump/autojump-21.5.8.ebuild)7
-rw-r--r--app-shells/autojump/files/autojump-21.5.8-eprefix.patch13
4 files changed, 72 insertions, 17 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
index e7836bd0747b..d3c300ac2344 100644
--- a/app-shells/autojump/ChangeLog
+++ b/app-shells/autojump/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/autojump
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.12 2013/05/04 11:14:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.13 2013/08/06 22:02:54 xmw Exp $
+
+*autojump-21.5.8-r1 (06 Aug 2013)
+*autojump-21.6.9 (06 Aug 2013)
+
+ 06 Aug 2013; Michael Weber <xmw@gentoo.org> +autojump-21.5.8-r1.ebuild,
+ +autojump-21.6.9.ebuild, -autojump-21.5.8.ebuild,
+ -files/autojump-21.5.8-eprefix.patch:
+ Fix EPREFIX handling (thanks Leho Kraav, bug 465226), version bump.
*autojump-21.5.8 (04 May 2013)
diff --git a/app-shells/autojump/autojump-21.5.8-r1.ebuild b/app-shells/autojump/autojump-21.5.8-r1.ebuild
new file mode 100644
index 000000000000..1549b7a028bb
--- /dev/null
+++ b/app-shells/autojump/autojump-21.5.8-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.5.8-r1.ebuild,v 1.1 2013/08/06 22:02:54 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit python-r1 python-utils-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion python test zsh-completion"
+
+RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ python? ( ${PYTHON_DEPS} )
+ zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -i bin/autojump.sh || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+}
diff --git a/app-shells/autojump/autojump-21.5.8.ebuild b/app-shells/autojump/autojump-21.6.9.ebuild
index 0048e8169f90..0b6560c55c01 100644
--- a/app-shells/autojump/autojump-21.5.8.ebuild
+++ b/app-shells/autojump/autojump-21.6.9.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.5.8.ebuild,v 1.1 2013/05/04 11:14:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.6.9.ebuild,v 1.1 2013/08/06 22:02:54 xmw Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
-inherit eutils python-r1 python-utils-r1 vcs-snapshot
+inherit python-r1 python-utils-r1 vcs-snapshot
DESCRIPTION="change directory command that learns"
HOMEPAGE="http://github.com/joelthelion/autojump"
@@ -23,7 +23,8 @@ RDEPEND="bash-completion? ( >=app-shells/bash-4 )
DEPEND="test? ( ${PYTHON_DEPS} )"
src_prepare() {
- epatch "${FILESDIR}"/${P}-eprefix.patch
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -i bin/autojump.sh || die
}
src_compile() {
diff --git a/app-shells/autojump/files/autojump-21.5.8-eprefix.patch b/app-shells/autojump/files/autojump-21.5.8-eprefix.patch
deleted file mode 100644
index 3daec004b32c..000000000000
--- a/app-shells/autojump/files/autojump-21.5.8-eprefix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- autojump-21.5.8/bin/autojump.sh
-+++ autojump-21.5.8/bin/autojump.sh
-@@ -11,8 +11,8 @@
- source ~/.autojump/etc/profile.d/autojump.${shell}
-
- # check global install
--elif [ -s /etc/profile.d/autojump.${shell} ]; then
-- source /etc/profile.d/autojump.${shell}
-+elif [ -s "${EPREFIX}"/etc/profile.d/autojump.${shell} ]; then
-+ source "${EPREFIX}"/etc/profile.d/autojump.${shell}
-
- # check custom install locations (modified by Homebrew or using --destdir option)
- #custom# elif [ -s destdir_install/autojump.${shell} ]; then