summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-08 09:26:07 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-08 09:26:07 +0000
commite3b22c5c052417707c070c8de57ab6ac1ddcbaf7 (patch)
treed3335ea5d0c72ca910820546999187732910dcd4 /app-shells
parentmake /etc/fstab check ignore commented out entries, fix bash parse error in g... (diff)
downloadgentoo-2-e3b22c5c052417707c070c8de57ab6ac1ddcbaf7.tar.gz
gentoo-2-e3b22c5c052417707c070c8de57ab6ac1ddcbaf7.tar.bz2
gentoo-2-e3b22c5c052417707c070c8de57ab6ac1ddcbaf7.zip
sash is now always built to be static
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/ChangeLog16
-rw-r--r--app-shells/sash/files/digest-sash-3.4-r42
-rw-r--r--app-shells/sash/sash-3.4-r4.ebuild49
3 files changed, 58 insertions, 9 deletions
diff --git a/app-shells/sash/ChangeLog b/app-shells/sash/ChangeLog
index 7f313dbc4977..478b2eec94cf 100644
--- a/app-shells/sash/ChangeLog
+++ b/app-shells/sash/ChangeLog
@@ -1,13 +1,11 @@
# ChangeLog for app-shells/sash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.1 2002/02/01 21:53:09 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.2 2002/03/08 09:26:06 blocke Exp $
-*sash-3.4-r3 (1 Feb 2002)
+*sash-3.4-r4 (8 Mar 2002)
+
+ 8 Mar 2002; Bruce A. Locke <blocke@gentoo.org> sash-3.4-r4.ebuild:
+
+ sash is always static now... previous versions were only built statically
+ if 'static' USE keyword was set
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/app-shells/sash/files/digest-sash-3.4-r4 b/app-shells/sash/files/digest-sash-3.4-r4
new file mode 100644
index 000000000000..932680c25ee4
--- /dev/null
+++ b/app-shells/sash/files/digest-sash-3.4-r4
@@ -0,0 +1,2 @@
+MD5 9c631eb171371b69276ff6692100beb6 sash-3.4.tar.gz 49149
+MD5 43cbfb670d42e6e15b58f3b528f75ca0 sash-3.x-readline.diff.gz 3181
diff --git a/app-shells/sash/sash-3.4-r4.ebuild b/app-shells/sash/sash-3.4-r4.ebuild
new file mode 100644
index 000000000000..ae554b35d26a
--- /dev/null
+++ b/app-shells/sash/sash-3.4-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r4.ebuild,v 1.1 2002/03/08 09:26:07 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small static UNIX Shell with readline suppport"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ if [ "`use readline`" ]
+ then
+ gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" -e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
+ else
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" Makefile.orig > Makefile
+ fi
+}
+
+src_compile() {
+
+ make || die
+
+}
+
+src_install() {
+
+ into /
+ dobin sash
+ into /usr
+ doman sash.1
+ dodoc README
+
+}
+