summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2009-01-03 21:08:10 +0000
committerMike Pagano <mpagano@gentoo.org>2009-01-03 21:08:10 +0000
commitf56d74156ad9e6a8781ef7208f3c7b0d7c418704 (patch)
tree2b28660caad90fbe41dcc4a110800818b0d1b0e2 /app-text/7plus/7plus-2.25.ebuild
parentVersion bump to match sys-boot/grub (diff)
downloadgentoo-2-f56d74156ad9e6a8781ef7208f3c7b0d7c418704.tar.gz
gentoo-2-f56d74156ad9e6a8781ef7208f3c7b0d7c418704.tar.bz2
gentoo-2-f56d74156ad9e6a8781ef7208f3c7b0d7c418704.zip
Fix for respecting CFLAGS bug #240125 and prestriping binaries bug #240108. Patch submitted by Thomas Beierlein. Thank-you, Thomas.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'app-text/7plus/7plus-2.25.ebuild')
-rw-r--r--app-text/7plus/7plus-2.25.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-text/7plus/7plus-2.25.ebuild b/app-text/7plus/7plus-2.25.ebuild
index c88821f725ee..879799c8dbe9 100644
--- a/app-text/7plus/7plus-2.25.ebuild
+++ b/app-text/7plus/7plus-2.25.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/7plus/7plus-2.25.ebuild,v 1.6 2005/05/30 18:15:07 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/7plus/7plus-2.25.ebuild,v 1.7 2009/01/03 21:08:10 mpagano Exp $
inherit toolchain-funcs
@@ -19,9 +19,10 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -e "s:CC = gcc:CC = $(tc-getCC):" \
- -e "s:-O2:${CFLAGS}:" linux.mak > Makefile \
+ -e "s:= -O2:+=:" \
+ -e "s:LDFLAGS = -s:LDFLAGS =:" linux.mak > Makefile \
|| die "sed Makefile failed"
}