summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-05-30 20:50:04 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-05-30 20:50:04 +0000
commitc95a5c766a18bec6bc67d3b9b1fc1fe2c5978c82 (patch)
treedc8aef7065ca75824519e409d5e348f6db0a0fdd /app-text/a2ps
parentFix for gcc-4.1, bug #134265 (diff)
downloadgentoo-2-c95a5c766a18bec6bc67d3b9b1fc1fe2c5978c82.tar.gz
gentoo-2-c95a5c766a18bec6bc67d3b9b1fc1fe2c5978c82.tar.bz2
gentoo-2-c95a5c766a18bec6bc67d3b9b1fc1fe2c5978c82.zip
Added patch that allows to compile on systems with broken fnmatch function (like with uClibc). Fixes bug #134546.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'app-text/a2ps')
-rw-r--r--app-text/a2ps/ChangeLog7
-rw-r--r--app-text/a2ps/a2ps-4.13c-r4.ebuild5
-rw-r--r--app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch43
-rw-r--r--app-text/a2ps/files/digest-a2ps-4.13c-r26
-rw-r--r--app-text/a2ps/files/digest-a2ps-4.13c-r36
5 files changed, 63 insertions, 4 deletions
diff --git a/app-text/a2ps/ChangeLog b/app-text/a2ps/ChangeLog
index 1c797266d35e..18edf3d680a5 100644
--- a/app-text/a2ps/ChangeLog
+++ b/app-text/a2ps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/a2ps
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.45 2006/02/17 01:41:30 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.46 2006/05/30 20:50:04 yvasilev Exp $
+
+ 30 May 2006; <yvasilev@gentoo.org>
+ +files/a2ps-4.13c-fnmatch-replacement.patch, a2ps-4.13c-r4.ebuild:
+ Added patch that allows to compile on systems with broken fnmatch function
+ (like with uClibc). Fixes bug #134546.
17 Feb 2006; Marcelo Goes <vanquirius@gentoo.org> a2ps-4.13c-r2.ebuild,
a2ps-4.13c-r3.ebuild, a2ps-4.13c-r4.ebuild:
diff --git a/app-text/a2ps/a2ps-4.13c-r4.ebuild b/app-text/a2ps/a2ps-4.13c-r4.ebuild
index a64ac9c9fa93..9cbc043ab81f 100644
--- a/app-text/a2ps/a2ps-4.13c-r4.ebuild
+++ b/app-text/a2ps/a2ps-4.13c-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.13c-r4.ebuild,v 1.2 2006/02/17 01:41:30 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.13c-r4.ebuild,v 1.3 2006/05/30 20:50:04 yvasilev Exp $
inherit gnuconfig eutils
@@ -43,6 +43,9 @@ src_unpack() {
epatch ${FILESDIR}/${P}-fixps.patch
epatch ${FILESDIR}/${P}-psmandup.diff
+ # fix fnmatch replacement, bug #134546
+ epatch ${FILESDIR}/${P}-fnmatch-replacement.patch
+
# fix sandbox violation, bug #79012
sed -i -e 's:$acroread -helpall:acroread4 -helpall:' configure configure.in
diff --git a/app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch b/app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch
new file mode 100644
index 000000000000..c49ab78c93c0
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch
@@ -0,0 +1,43 @@
+diff -Naurp a2ps-4.13.orig/lib/fnmatch.c a2ps-4.13/lib/fnmatch.c
+--- a2ps-4.13.orig/lib/fnmatch.c 2002-03-04 12:46:25 -0600
++++ a2ps-4.13/lib/fnmatch.c 2006-05-27 11:41:15 -0500
+@@ -27,18 +27,6 @@
+ #include <fnmatch.h>
+ #include <ctype.h>
+
+-
+-/* Comment out all this code if we are using the GNU C Library, and are not
+- actually compiling the library itself. This code is part of the GNU C
+- Library, but also included in many other GNU distributions. Compiling
+- and linking in this code is a waste when using the GNU C library
+- (especially if it is a shared library). Rather than having every GNU
+- program understand `configure --with-gnu-libc' and omit the object files,
+- it is simpler to just do this in the source for each such file. */
+-
+-#if defined _LIBC || !defined __GNU_LIBRARY__
+-
+-
+ # if defined STDC_HEADERS || !defined isascii
+ # define ISASCII(c) 1
+ # else
+@@ -52,10 +40,13 @@
+ extern int errno;
+ # endif
+
++/* fnmatch replacement taken from the GNU C Library for systems that
++ provide a broken implementation. */
++
+ /* Match STRING against the filename pattern PATTERN, returning zero if
+ it matches, nonzero if not. */
+ int
+-fnmatch (const char *pattern, const char *string, int flags)
++rpl_fnmatch (const char *pattern, const char *string, int flags)
+ {
+ register const char *p = pattern, *n = string;
+ register char c;
+@@ -233,5 +224,3 @@ fnmatch (const char *pattern, const char
+
+ # undef FOLD
+ }
+-
+-#endif /* _LIBC or not __GNU_LIBRARY__. */
diff --git a/app-text/a2ps/files/digest-a2ps-4.13c-r2 b/app-text/a2ps/files/digest-a2ps-4.13c-r2
index 4abfd89450cb..0cf5230e7350 100644
--- a/app-text/a2ps/files/digest-a2ps-4.13c-r2
+++ b/app-text/a2ps/files/digest-a2ps-4.13c-r2
@@ -1,2 +1,6 @@
-MD5 97164e84ba911e4604155507e0893669 a2ps-4.13c.tar.gz 2395885
MD5 e315466f75d99c0c1ca563d82f2ace2e a2ps-4.13c-ja_nls.patch.gz 38189
+RMD160 932f430064f77d65768d2d1701ea650ae1103bb0 a2ps-4.13c-ja_nls.patch.gz 38189
+SHA256 8bc15ae152205b184a609777ac29430780eadacba2fd90bfa1fe318e43bd781f a2ps-4.13c-ja_nls.patch.gz 38189
+MD5 97164e84ba911e4604155507e0893669 a2ps-4.13c.tar.gz 2395885
+RMD160 d6464e88236a4efa8377e37e29e548411cd9c863 a2ps-4.13c.tar.gz 2395885
+SHA256 dfdd509ef79040fb300b2709a8fc54d9562f3ce141184958e3c2303cb3cf4890 a2ps-4.13c.tar.gz 2395885
diff --git a/app-text/a2ps/files/digest-a2ps-4.13c-r3 b/app-text/a2ps/files/digest-a2ps-4.13c-r3
index 4abfd89450cb..0cf5230e7350 100644
--- a/app-text/a2ps/files/digest-a2ps-4.13c-r3
+++ b/app-text/a2ps/files/digest-a2ps-4.13c-r3
@@ -1,2 +1,6 @@
-MD5 97164e84ba911e4604155507e0893669 a2ps-4.13c.tar.gz 2395885
MD5 e315466f75d99c0c1ca563d82f2ace2e a2ps-4.13c-ja_nls.patch.gz 38189
+RMD160 932f430064f77d65768d2d1701ea650ae1103bb0 a2ps-4.13c-ja_nls.patch.gz 38189
+SHA256 8bc15ae152205b184a609777ac29430780eadacba2fd90bfa1fe318e43bd781f a2ps-4.13c-ja_nls.patch.gz 38189
+MD5 97164e84ba911e4604155507e0893669 a2ps-4.13c.tar.gz 2395885
+RMD160 d6464e88236a4efa8377e37e29e548411cd9c863 a2ps-4.13c.tar.gz 2395885
+SHA256 dfdd509ef79040fb300b2709a8fc54d9562f3ce141184958e3c2303cb3cf4890 a2ps-4.13c.tar.gz 2395885