summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-11-09 21:31:36 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-11-09 21:31:36 +0000
commit017315c90c7ee3629bf2b542baa4f30899441b3b (patch)
treeb86808f2b9b2bd61b8f0f36e8bdf853da7b56454 /app-text/aspell/aspell-0.60.4.ebuild
parentVersion bumped. This version includes some bugfixes. (diff)
downloadgentoo-2-017315c90c7ee3629bf2b542baa4f30899441b3b.tar.gz
gentoo-2-017315c90c7ee3629bf2b542baa4f30899441b3b.tar.bz2
gentoo-2-017315c90c7ee3629bf2b542baa4f30899441b3b.zip
new version
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-text/aspell/aspell-0.60.4.ebuild')
-rw-r--r--app-text/aspell/aspell-0.60.4.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-text/aspell/aspell-0.60.4.ebuild b/app-text/aspell/aspell-0.60.4.ebuild
new file mode 100644
index 000000000000..4d6a4b786b0a
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.4.ebuild,v 1.1 2005/11/09 21:31:36 arj Exp $
+
+inherit libtool eutils flag-o-matic
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc-macos ~ppc"
+IUSE="gpm"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/aspell-0.60.3-templateinstantiations.patch
+}
+
+src_compile() {
+ [ "${ARCH}" == "ppc" ] && append-flags -O2 -fsigned-char
+ use gpm && append-ldflags -lgpm
+ filter-flags -fno-rtti
+ filter-flags -fvisibility=hidden #77109
+ elibtoolize --reverse-deps
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR="${D}" install || die
+ mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+
+ ewarn ""
+ ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
+ ewarn ""
+ ebeep 5
+}