summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-12-12 10:25:59 +0000
committerZac Medico <zmedico@gentoo.org>2012-12-12 10:25:59 +0000
commitdbd507e4f24112f1de051be88ae408b255053c74 (patch)
tree02bf56460e9b5a65772b544e465ff2ea9c5784c5 /app-text/calibre
parentInitial commit wrt bug #446710. Ebuild is written by Mikle Kolyada, who will ... (diff)
downloadgentoo-2-dbd507e4f24112f1de051be88ae408b255053c74.tar.gz
gentoo-2-dbd507e4f24112f1de051be88ae408b255053c74.tar.bz2
gentoo-2-dbd507e4f24112f1de051be88ae408b255053c74.zip
Add workaround for PyQt4-4.9.6 compile failure, bug #446790.
(Portage version: 2.2.0_alpha148/cvs/Linux i686, signed Manifest commit with key 0xFDE8EF85AE5719A3)
Diffstat (limited to 'app-text/calibre')
-rw-r--r--app-text/calibre/ChangeLog5
-rw-r--r--app-text/calibre/calibre-0.9.9.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/app-text/calibre/ChangeLog b/app-text/calibre/ChangeLog
index 81c0498071c4..4331a023044e 100644
--- a/app-text/calibre/ChangeLog
+++ b/app-text/calibre/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/calibre
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.245 2012/12/08 03:26:02 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.246 2012/12/12 10:25:59 zmedico Exp $
+
+ 12 Dec 2012; Zac Medico <zmedico@gentoo.org> calibre-0.9.9.ebuild:
+ Add workaround for PyQt4-4.9.6 compile failure, bug #446790.
*calibre-0.9.9 (08 Dec 2012)
diff --git a/app-text/calibre/calibre-0.9.9.ebuild b/app-text/calibre/calibre-0.9.9.ebuild
index 2f01c7f79e8c..d11b755f13d6 100644
--- a/app-text/calibre/calibre-0.9.9.ebuild
+++ b/app-text/calibre/calibre-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/calibre-0.9.9.ebuild,v 1.1 2012/12/08 03:26:02 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/calibre-0.9.9.ebuild,v 1.2 2012/12/12 10:25:59 zmedico Exp $
EAPI=4
PYTHON_DEPEND=2:2.7
@@ -88,6 +88,12 @@ src_prepare() {
'-e', 's|^LFLAGS .*|\\\\\\\\0 ${LDFLAGS}|', \
'-i', 'Makefile'])" \
-i setup/extensions.py || die "sed failed to patch extensions.py"
+
+ # Disable destructive regex for Bug #446790.
+ if has_version '>=dev-python/PyQt4-4.9.6' ; then
+ sed -e "s|dat = re\.compile(r'QtGui\.QApplication\.translate.*|#\\0|" \
+ -i src/calibre/gui2/__init__.py || die
+ fi
}
src_install() {