summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-11-13 10:24:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-11-13 10:24:00 +0000
commit3cf9c2f0930e399ce77175c9d6bbae719fe87b3f (patch)
treeed8f118b7cc3ed063866f5f3b2b530ecca81b36f /app-text/convmv/convmv-1.10.ebuild
parentMarked ppc stable for bug #153260. (diff)
downloadgentoo-2-3cf9c2f0930e399ce77175c9d6bbae719fe87b3f.tar.gz
gentoo-2-3cf9c2f0930e399ce77175c9d6bbae719fe87b3f.tar.bz2
gentoo-2-3cf9c2f0930e399ce77175c9d6bbae719fe87b3f.zip
Bug #151071, fix testsuite making assumptions about filesystem.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'app-text/convmv/convmv-1.10.ebuild')
-rw-r--r--app-text/convmv/convmv-1.10.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/app-text/convmv/convmv-1.10.ebuild b/app-text/convmv/convmv-1.10.ebuild
index ce325f1b20fb..5a559c74a0b6 100644
--- a/app-text/convmv/convmv-1.10.ebuild
+++ b/app-text/convmv/convmv-1.10.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.10.ebuild,v 1.2 2006/10/02 22:36:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.10.ebuild,v 1.3 2006/11/13 10:24:00 robbat2 Exp $
+
+inherit eutils
DESCRIPTION="convert filenames to utf8 or any other charset"
HOMEPAGE="http://j3e.de/linux/convmv"
@@ -19,5 +21,14 @@ src_compile() {
src_install() {
einstall DESTDIR=${D} PREFIX=/usr || die "einstall failed"
- dodoc CREDITS Changes GPL2 TODO VERSION testsuite.tar
+ dodoc CREDITS Changes TODO VERSION
+}
+
+src_test() {
+ cd ${S}
+ tar xf testsuite.tar
+ # Never make assumptions as to the ordering of files inside a directory!
+ epatch ${FILESDIR}/${PN}-1.10-testcase-cleanup.patch
+ cd ${S}/suite
+ ./dotests.sh || die "Tests failed"
}