summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-30 23:32:56 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-30 23:32:56 +0000
commit80a81770b4445225fb1636a066e8c6f50a1d7b91 (patch)
tree96b1921e1420cf45d007fc3fa57d43d3ad58de9c /app-text/crf++
parentVersion bump and removed deprecated (diff)
downloadgentoo-2-80a81770b4445225fb1636a066e8c6f50a1d7b91.tar.gz
gentoo-2-80a81770b4445225fb1636a066e8c6f50a1d7b91.tar.bz2
gentoo-2-80a81770b4445225fb1636a066e8c6f50a1d7b91.zip
Version bumped, bug #356959. Fixed to build with gcc-4.6, bug #365921. Added static-libs USE flag. Removed *.la files.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-text/crf++')
-rw-r--r--app-text/crf++/ChangeLog12
-rw-r--r--app-text/crf++/crf++-0.50.ebuild42
-rw-r--r--app-text/crf++/crf++-0.54.ebuild (renamed from app-text/crf++/crf++-0.51.ebuild)29
-rw-r--r--app-text/crf++/files/crf++-0.50-gcc43.patch31
-rw-r--r--app-text/crf++/files/crf++-0.54-gcc46.patch11
5 files changed, 41 insertions, 84 deletions
diff --git a/app-text/crf++/ChangeLog b/app-text/crf++/ChangeLog
index 30b953df155b..3d7b54c82293 100644
--- a/app-text/crf++/ChangeLog
+++ b/app-text/crf++/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/crf++
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/crf++/ChangeLog,v 1.11 2010/12/02 01:18:51 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/crf++/ChangeLog,v 1.12 2011/05/30 23:32:56 matsuu Exp $
+
+*crf++-0.54 (30 May 2011)
+
+ 30 May 2011; MATSUU Takuto <matsuu@gentoo.org> -crf++-0.50.ebuild,
+ -files/crf++-0.50-gcc43.patch, -crf++-0.51.ebuild, +crf++-0.54.ebuild,
+ +files/crf++-0.54-gcc46.patch:
+ Version bumped, bug #356959. Fixed to build with gcc-4.6, bug #365921. Added
+ static-libs USE flag. Removed *.la files. Removed old versions.
02 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> crf++-0.51.ebuild,
crf++-0.53.ebuild:
diff --git a/app-text/crf++/crf++-0.50.ebuild b/app-text/crf++/crf++-0.50.ebuild
deleted file mode 100644
index a40c648c0939..000000000000
--- a/app-text/crf++/crf++-0.50.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/crf++/crf++-0.50.ebuild,v 1.1 2008/06/15 20:59:21 loki_val Exp $
-
-inherit eutils base
-
-MY_P="${P/crf/CRF}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
-HOMEPAGE="http://crfpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/crfpp/${MY_P}.tar.gz"
-
-LICENSE="BSD LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-
-IUSE="examples"
-
-DEPEND=""
-
-PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
-
-src_test() {
- for task in example/* ; do
- cd ${task}
- ./exec.sh || die "failed test in ${task}"
- cd -
- done
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- dodoc AUTHORS README
- dohtml doc/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r example
- fi
-}
diff --git a/app-text/crf++/crf++-0.51.ebuild b/app-text/crf++/crf++-0.54.ebuild
index 1807e4e52a61..14581762a83b 100644
--- a/app-text/crf++/crf++-0.51.ebuild
+++ b/app-text/crf++/crf++-0.54.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/crf++/crf++-0.51.ebuild,v 1.2 2010/12/02 01:18:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/crf++/crf++-0.54.ebuild,v 1.1 2011/05/30 23:32:56 matsuu Exp $
+EAPI="3"
inherit autotools eutils
MY_P="${P/crf/CRF}"
@@ -12,20 +13,26 @@ SRC_URI="mirror://sourceforge/crfpp/${MY_P}.tar.gz"
LICENSE="|| ( BSD LGPL-2.1 )"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="examples"
+IUSE="examples static-libs"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e "/CFLAGS/s/-O3/${CFLAGS}/" \
-e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
configure.in || die
+
+ # bug #365921
+ epatch "${FILESDIR}/${P}-gcc46.patch"
+
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static) || die
+}
+
src_test() {
for task in example/* ; do
(
@@ -38,11 +45,15 @@ src_test() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS README
- dohtml doc/*
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ dodoc AUTHORS README || die
+ dohtml -r doc/* || die
if use examples ; then
insinto /usr/share/doc/${PF}
- doins -r example
+ doins -r example || die
fi
}
diff --git a/app-text/crf++/files/crf++-0.50-gcc43.patch b/app-text/crf++/files/crf++-0.50-gcc43.patch
deleted file mode 100644
index 0809520dc676..000000000000
--- a/app-text/crf++/files/crf++-0.50-gcc43.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -NrU5 CRF++-0.50.orig/freelist.h CRF++-0.50/freelist.h
---- CRF++-0.50.orig/freelist.h 2008-06-15 22:42:21.000000000 +0200
-+++ CRF++-0.50/freelist.h 2008-06-15 22:47:44.000000000 +0200
-@@ -7,10 +7,11 @@
- //
- #ifndef CRFPP_FREELIST_H__
- #define CRFPP_FREELIST_H__
-
- #include <vector>
-+#include <cstring>
-
- namespace CRFPP {
- template <class T>
- class Length {
- public:
-diff -NrU5 CRF++-0.50.orig/param.h CRF++-0.50/param.h
---- CRF++-0.50.orig/param.h 2008-06-15 22:42:21.000000000 +0200
-+++ CRF++-0.50/param.h 2008-06-15 22:44:33.000000000 +0200
-@@ -28,11 +28,11 @@
- }
- return result;
- }
-
- template <>
-- static std::string lexical_cast<std::string, std::string>(std::string arg) {
-+ std::string lexical_cast<std::string, std::string>(std::string arg) {
- return arg;
- }
-
- struct Option {
- const char *name;
diff --git a/app-text/crf++/files/crf++-0.54-gcc46.patch b/app-text/crf++/files/crf++-0.54-gcc46.patch
new file mode 100644
index 000000000000..93cb54020cfc
--- /dev/null
+++ b/app-text/crf++/files/crf++-0.54-gcc46.patch
@@ -0,0 +1,11 @@
+diff -Naur CRF++-0.54.orig/path.h CRF++-0.54/path.h
+--- CRF++-0.54.orig/path.h 2009-04-05 20:42:35.000000000 +0900
++++ CRF++-0.54/path.h 2011-05-31 01:31:43.845198215 +0900
+@@ -8,6 +8,7 @@
+ #ifndef CRFPP_PATH_H_
+ #define CRFPP_PATH_H_
+
++#include <cstddef>
+ #include <vector>
+ #include "node.h"
+