summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-03 14:52:23 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-03 14:52:23 +0000
commit38e4157f416022ff9c13c4a850866490ee2c0699 (patch)
treefa65949262c6c3405584a47bcaa3bb85768453b2 /app-text/dgs/dgs-0.5.10-r1.ebuild
parentStable on sparc wrt bug #46258. (Manifest recommit) (diff)
downloadgentoo-2-38e4157f416022ff9c13c4a850866490ee2c0699.tar.gz
gentoo-2-38e4157f416022ff9c13c4a850866490ee2c0699.tar.bz2
gentoo-2-38e4157f416022ff9c13c4a850866490ee2c0699.zip
Added tcpd IUSE flag check. Thanks to Cory Visi <cory@visi.name> for the suggestion. Closing bug #34016
Diffstat (limited to 'app-text/dgs/dgs-0.5.10-r1.ebuild')
-rw-r--r--app-text/dgs/dgs-0.5.10-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-text/dgs/dgs-0.5.10-r1.ebuild b/app-text/dgs/dgs-0.5.10-r1.ebuild
index c8695c31f061..5dfffae9dd8c 100644
--- a/app-text/dgs/dgs-0.5.10-r1.ebuild
+++ b/app-text/dgs/dgs-0.5.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.21 2004/03/07 19:31:20 psi29a Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.22 2004/04/03 14:52:23 usata Exp $
inherit gnuconfig
@@ -11,12 +11,20 @@ HOMEPAGE="http://www.gyve.org/dgs/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc alpha amd64 hppa ~mips"
+IUSE="tcpd"
RDEPEND="=dev-libs/glib-1.2*
virtual/x11"
DEPEND="${RDEPEND}
sys-apps/texinfo
- >=sys-apps/tcp-wrappers-7.6"
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+pkg_setup() {
+ if has_version 'sys-apps/tcp-wrappers' && [ -z "`use tcpd`" ]; then
+ ewarn "tcp-wrappers will be detected by the package and support will be enabled"
+ ewarn "The package presently provides no way to disable tcp-wrappers support if you don't want it"
+ fi
+}
src_unpack() {
unpack ${A}
@@ -26,12 +34,12 @@ src_unpack() {
}
src_compile() {
- econf --with-x
+ econf --with-x || die
make || die
}
src_install() {
- einstall
+ einstall || die
rm -rf ${D}/usr/share/man/manm
newman ${S}/DPS/demos/xepsf/xepsf.man xepsf.1