summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-29 09:19:03 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-29 09:19:03 +0000
commit6ea1cd5ff04b8295e308badc26dd7862e16b8b12 (patch)
treef60128f3a1b4e1780526462ec8fb3bf86e623bd5 /app-text/dictd/dictd-1.9.7.ebuild
parentversion bump, thanks to: José Romildo Malaquias <romildo@uber.com.br> in bug ... (diff)
downloadgentoo-2-6ea1cd5ff04b8295e308badc26dd7862e16b8b12.tar.gz
gentoo-2-6ea1cd5ff04b8295e308badc26dd7862e16b8b12.tar.bz2
gentoo-2-6ea1cd5ff04b8295e308badc26dd7862e16b8b12.zip
version bump, thanks to: José Romildo Malaquias <romildo@uber.com.br> in bug #36638
Diffstat (limited to 'app-text/dictd/dictd-1.9.7.ebuild')
-rw-r--r--app-text/dictd/dictd-1.9.7.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-text/dictd/dictd-1.9.7.ebuild b/app-text/dictd/dictd-1.9.7.ebuild
new file mode 100644
index 000000000000..5374b2286795
--- /dev/null
+++ b/app-text/dictd/dictd-1.9.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.9.7.ebuild,v 1.1 2003/12/29 09:18:56 seemant Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="ftp://ftp.dict.org/pub/dict/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64 ~ppc64"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ # Update config.sub and config.guess so dictd understands the sparc architecture
+ gnuconfig_update
+
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --with-etcdir=/etc/dict || die
+ make || die
+}
+
+src_install() {
+ # gotta set up the dirs for it....
+ dodir /usr/bin
+ dodir /usr/sbin
+ dodir /usr/share/man/man1
+ dodir /usr/share/man/man8
+
+ # Now install it.
+ make \
+ prefix=${D}/usr \
+ man1_prefix=${D}/usr/share/man/man1 \
+ man8_prefix=${D}/usr/share/man/man8 \
+ conf=${D}/etc/dict \
+ install || die
+
+ # Install docs
+ dodoc README TODO COPYING ChangeLog ANNOUNCE
+ dodoc doc/dicf.ms doc/rfc.ms doc/rfc.sh doc/rfc2229.txt
+ dodoc doc/security.doc doc/toc.ms
+
+ # conf files.
+ dodir /etc/dict
+ insinto /etc/dict
+ doins ${FILESDIR}/${PVR}/dict.conf
+ doins ${FILESDIR}/${PVR}/dictd.conf
+ doins ${FILESDIR}/${PVR}/site.info
+
+ # startups for dictd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PVR}/dictd dictd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PVR}/dictd.confd dictd
+}