summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-22 22:37:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-22 22:37:40 +0000
commit97fa0825c7db173f16fc878156ca8a4959172121 (patch)
treecda8618c6c5c982f398734de3da5109130315537 /app-text/docbook-xsl-ns-stylesheets
parentVersion bump, added tests like for docbook-xsl-ns but restrict them for now s... (diff)
downloadgentoo-2-97fa0825c7db173f16fc878156ca8a4959172121.tar.gz
gentoo-2-97fa0825c7db173f16fc878156ca8a4959172121.tar.bz2
gentoo-2-97fa0825c7db173f16fc878156ca8a4959172121.zip
Version bump, restrict tests because the Makefile is broken.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/docbook-xsl-ns-stylesheets')
-rw-r--r--app-text/docbook-xsl-ns-stylesheets/ChangeLog8
-rw-r--r--app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.75.0.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/app-text/docbook-xsl-ns-stylesheets/ChangeLog b/app-text/docbook-xsl-ns-stylesheets/ChangeLog
index b0bb847a937a..d684db81d0d7 100644
--- a/app-text/docbook-xsl-ns-stylesheets/ChangeLog
+++ b/app-text/docbook-xsl-ns-stylesheets/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/docbook-xsl-ns-stylesheets
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-ns-stylesheets/ChangeLog,v 1.9 2009/03/04 20:58:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-ns-stylesheets/ChangeLog,v 1.10 2009/05/22 22:37:40 flameeyes Exp $
+
+*docbook-xsl-ns-stylesheets-1.75.0 (22 May 2009)
+
+ 22 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +docbook-xsl-ns-stylesheets-1.75.0.ebuild:
+ Version bump, restrict tests because the Makefile is broken.
*docbook-xsl-ns-stylesheets-1.74.0-r1 (04 Mar 2009)
diff --git a/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.75.0.ebuild b/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.75.0.ebuild
new file mode 100644
index 000000000000..e39b07a7d281
--- /dev/null
+++ b/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.75.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.75.0.ebuild,v 1.1 2009/05/22 22:37:40 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="http://wiki.docbook.org/topic/DocBookXslStylesheets"
+SRC_URI="mirror://sourceforge/docbook/docbook-xsl-ns-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-libs/libxml2
+ dev-libs/libxslt )"
+
+RDEPEND=">=app-text/build-docbook-catalog-1.4"
+
+S=${WORKDIR}/docbook-xsl-ns-${PV}
+
+# Makefile is broken in this release
+RESTRICT=test
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check || die "test failed"
+}
+
+src_install() {
+ # Create the installation directory
+ DEST="/usr/share/sgml/docbook/xsl-ns-stylesheets"
+ insinto ${DEST}
+
+ local i
+ for sheet in $(find . -maxdepth 1 -mindepth 1 -type d); do
+ i=$(basename $sheet)
+ cd "${S}"/${i}
+ for doc in ChangeLog README; do
+ if [ -e "$doc" ]; then
+ mv ${doc} ${doc}.${i}
+ dodoc ${doc}.${i}
+ rm ${doc}.${i}
+ fi
+ done
+
+ doins -r "${S}"/${i}
+ done
+
+ # Install misc. docs
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ cd "${S}"
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+ doins VERSION
+}
+
+pkg_postinst() {
+ build-docbook-catalog
+}
+
+pkg_postrm() {
+ build-docbook-catalog
+}