summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-27 07:57:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-27 07:57:17 +0000
commit18fdbe707bb26ffac08a2994d58b176e74a86299 (patch)
tree93707f798086370f4e23466fee78983496e03680 /app-text/dvisvgm
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-18fdbe707bb26ffac08a2994d58b176e74a86299.tar.gz
gentoo-2-18fdbe707bb26ffac08a2994d58b176e74a86299.tar.bz2
gentoo-2-18fdbe707bb26ffac08a2994d58b176e74a86299.zip
version bump, fix build with kpathsea from texlive 2015
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text/dvisvgm')
-rw-r--r--app-text/dvisvgm/ChangeLog7
-rw-r--r--app-text/dvisvgm/dvisvgm-1.10.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-text/dvisvgm/ChangeLog b/app-text/dvisvgm/ChangeLog
index 23fed5c9551c..591e4d96f650 100644
--- a/app-text/dvisvgm/ChangeLog
+++ b/app-text/dvisvgm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dvisvgm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dvisvgm/ChangeLog,v 1.77 2015/07/23 20:44:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvisvgm/ChangeLog,v 1.78 2015/07/27 07:57:17 aballier Exp $
+
+*dvisvgm-1.10 (27 Jul 2015)
+
+ 27 Jul 2015; Alexis Ballier <aballier@gentoo.org> +dvisvgm-1.10.ebuild:
+ version bump, fix build with kpathsea from texlive 2015
23 Jul 2015; Pacho Ramos <pacho@gentoo.org> dvisvgm-1.8.1.ebuild:
ppc stable wrt bug #534906
diff --git a/app-text/dvisvgm/dvisvgm-1.10.ebuild b/app-text/dvisvgm/dvisvgm-1.10.ebuild
new file mode 100644
index 000000000000..b3b125321ec7
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-1.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvisvgm/dvisvgm-1.10.ebuild,v 1.1 2015/07/27 07:57:17 aballier Exp $
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="http://dvisvgm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+# Tests don't work from $WORKDIR: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+RDEPEND="virtual/tex-base
+ app-text/ghostscript-gpl
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ dev-libs/kpathsea
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/xmlto
+ app-text/asciidoc
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ default
+}