summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-08-20 15:24:21 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-08-20 15:24:21 +0000
commitb3bbeeedba8bb05535f9cd6873835aef8a9c4eda (patch)
tree8baf089e2ee0ebc041b4c18c70f8b752635f32c4 /app-text/getxbook/getxbook-1.0.ebuild
parentStable for x86, wrt bug #431768 (diff)
downloadgentoo-2-b3bbeeedba8bb05535f9cd6873835aef8a9c4eda.tar.gz
gentoo-2-b3bbeeedba8bb05535f9cd6873835aef8a9c4eda.tar.bz2
gentoo-2-b3bbeeedba8bb05535f9cd6873835aef8a9c4eda.zip
Version bump
(Portage version: 2.2.0_alpha121/cvs/Linux i686)
Diffstat (limited to 'app-text/getxbook/getxbook-1.0.ebuild')
-rw-r--r--app-text/getxbook/getxbook-1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/getxbook/getxbook-1.0.ebuild b/app-text/getxbook/getxbook-1.0.ebuild
new file mode 100644
index 000000000000..dc7011f35dfd
--- /dev/null
+++ b/app-text/getxbook/getxbook-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/getxbook/getxbook-1.0.ebuild,v 1.1 2012/08/20 15:24:21 grozin Exp $
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Download books from google, amazon, barnes and noble."
+HOMEPAGE="http://njw.me.uk/software/getxbook/"
+SRC_URI="http://njw.me.uk/software/getxbook/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pdf djvu ocr tk"
+
+DEPEND=""
+RDEPEND="djvu? ( app-text/djvu )
+ pdf? ( media-gfx/imagemagick )
+ ocr? ( app-text/tesseract
+ pdf? ( media-gfx/exact-image app-text/pdftk ) )
+ tk? ( dev-lang/tk )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ tc-export CXX
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README LEGAL
+ exeinto /usr/bin
+ use pdf && doexe extras/mkpdf.sh
+ use djvu && doexe extras/mkdjvu.sh
+ if use ocr; then
+ doexe extras/mkocrtxt.sh
+ use pdf && doexe extras/mkocrpdf.sh
+ use djvu && doexe extras/mkocrdjvu.sh
+ fi
+ use tk && doexe getxbookgui.tcl
+}