summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-02-28 07:42:49 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-02-28 07:42:49 +0000
commit5ab7554bf1f6c7a40dc8306d1a6f37663fa28585 (patch)
tree8964dd9daab5f6e0ec3d148974877e1152e545a7 /app-text/html-xml-utils/html-xml-utils-3.6.ebuild
parentFixed compilation on ~x86. (diff)
downloadgentoo-2-5ab7554bf1f6c7a40dc8306d1a6f37663fa28585.tar.gz
gentoo-2-5ab7554bf1f6c7a40dc8306d1a6f37663fa28585.tar.bz2
gentoo-2-5ab7554bf1f6c7a40dc8306d1a6f37663fa28585.zip
Version bump. Closing #83435 by James Rowe <jnrowe@ukfsn.org>
(Portage version: 2.0.51.16)
Diffstat (limited to 'app-text/html-xml-utils/html-xml-utils-3.6.ebuild')
-rw-r--r--app-text/html-xml-utils/html-xml-utils-3.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/html-xml-utils/html-xml-utils-3.6.ebuild b/app-text/html-xml-utils/html-xml-utils-3.6.ebuild
new file mode 100644
index 000000000000..ebf8454e7702
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-3.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/html-xml-utils/html-xml-utils-3.6.ebuild,v 1.1 2005/02/28 07:42:49 pclouds Exp $
+
+inherit eutils
+
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files."
+SRC_URI="http://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+HOMEPAGE="http://www.w3.org/Tools/HTML-XML-utils/"
+LICENSE="W3C"
+
+IUSE=""
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Replace references to normalize with normalize-html, which
+ # has been renamed due to clash described in #27399
+ sed -i "s:normalize:&-html:g" *.1 || die "sed failed"
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING INSTALL README TODO
+
+ # Check bug #27399, the following binary conflicts with
+ # one provided by the 'normalize' package, so we're
+ # renaming this one <obz@gentoo.org>
+ mv ${D}/usr/bin/normalize ${D}/usr/bin/normalize-html
+ mv ${D}/usr/share/man/man1/normalize.1 \
+ ${D}/usr/share/man/man1/normalize-html.1
+
+}