summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-08 12:23:57 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-08 12:23:57 +0000
commit3a61fe643e84d3cd8a07cb62ba610546d5bf3c90 (patch)
treef869f2196ae52a36bd3960eeeb1e6cd16ebb6e29 /app-text/htmldoc/htmldoc-1.8.24.ebuild
parentCleaned up ebuild; Added a patch with some gcc-3.4 fixes as well replacing al... (diff)
downloadgentoo-2-3a61fe643e84d3cd8a07cb62ba610546d5bf3c90.tar.gz
gentoo-2-3a61fe643e84d3cd8a07cb62ba610546d5bf3c90.tar.bz2
gentoo-2-3a61fe643e84d3cd8a07cb62ba610546d5bf3c90.zip
Version bumped. This closes bug #75069.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-text/htmldoc/htmldoc-1.8.24.ebuild')
-rw-r--r--app-text/htmldoc/htmldoc-1.8.24.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-text/htmldoc/htmldoc-1.8.24.ebuild b/app-text/htmldoc/htmldoc-1.8.24.ebuild
new file mode 100644
index 000000000000..a59a57ea57a0
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.8.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmldoc/htmldoc-1.8.24.ebuild,v 1.1 2005/02/08 12:23:57 usata Exp $
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+SRC_URI="http://ftp.easysw.com/pub/${PN}/${PV}/${P}-source.tar.bz2"
+HOMEPAGE="http://www.easysw.com/htmldoc/"
+
+IUSE="X ssl"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+DEPEND="X? ( virtual/x11 )"
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6e )
+ X? ( >=x11-libs/fltk-1.0.11 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s@^#define DOCUMENTATION \"\$prefix/share/doc/htmldoc\"@#define DOCUMENTATION \"\$prefix/share/doc/${PF}/html\"@" \
+ configure
+}
+
+src_compile() {
+ local myconf
+ use X && myconf="--with-x --with-gui"
+ use ssl && myconf="${myconf} --with-openssl-libs=/usr/lib \
+ --with-openssl-includes=/usr/include/openssl"
+
+ econf ${myconf} || die "econf failed"
+
+ # Add missing -lfltk_images to LIBS
+ use X && sed -i 's/-lfltk /-lfltk -lfltk_images /g' Makedefs
+
+ make || die "make failed"
+}
+
+src_install() {
+ einstall bindir=${D}/usr/bin || die
+
+ # Minor cleanups
+ mv ${D}/usr/share/doc/htmldoc ${D}/usr/share/doc/${PF}
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/html
+}