summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-07-27 16:39:41 +0000
committerNed Ludd <solar@gentoo.org>2005-07-27 16:39:41 +0000
commit1a18bf89176bb2315f1fbfabd19dc7f1bdb82a06 (patch)
tree4a1ff5eba2f6b28a030441c1ca9681e2dd99af3b /app-text/pstotext/pstotext-1.8g-r1.ebuild
parentStable on hppa. (diff)
downloadgentoo-2-1a18bf89176bb2315f1fbfabd19dc7f1bdb82a06.tar.gz
gentoo-2-1a18bf89176bb2315f1fbfabd19dc7f1bdb82a06.tar.bz2
gentoo-2-1a18bf89176bb2315f1fbfabd19dc7f1bdb82a06.zip
- add patch from bug #100245 discovered by Max Vozeler to prevent arbitrary code execution by pstotext
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-text/pstotext/pstotext-1.8g-r1.ebuild')
-rw-r--r--app-text/pstotext/pstotext-1.8g-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/pstotext/pstotext-1.8g-r1.ebuild b/app-text/pstotext/pstotext-1.8g-r1.ebuild
new file mode 100644
index 000000000000..32b457fb842e
--- /dev/null
+++ b/app-text/pstotext/pstotext-1.8g-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.8g-r1.ebuild,v 1.1 2005/07/27 16:39:41 solar Exp $
+
+inherit eutils
+
+DESCRIPTION="extract ASCII text from a PostScript or PDF file"
+HOMEPAGE="http://research.compaq.com/SRC/virtualpaper/pstotext.html"
+SRC_URI="http://research.compaq.com/SRC/virtualpaper/binaries/pstotext.tar.Z"
+
+LICENSE="PSTT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/ncompress"
+
+RDEPEND="virtual/ghostscript"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${PN}-1.8g-dsafer.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ into /usr
+ dobin pstotext
+ doman pstotext.1
+}