summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-13 20:22:37 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-13 20:22:37 +0000
commit92a9d7597190047d28f29a5844b9180ab506425a (patch)
tree7c91a727f0e34a0c3a7aecba5efa2d132e20f472 /app-text/rfcutil/rfcutil-3.2.3-r1.ebuild
parentStable for AMD64, wrt security bug #394587 (diff)
downloadgentoo-2-92a9d7597190047d28f29a5844b9180ab506425a.tar.gz
gentoo-2-92a9d7597190047d28f29a5844b9180ab506425a.tar.bz2
gentoo-2-92a9d7597190047d28f29a5844b9180ab506425a.zip
Fix building rfc-index by Hartmut Figge, and thanks to Victor for the patch (bug #335152). Clean up old patch.
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'app-text/rfcutil/rfcutil-3.2.3-r1.ebuild')
-rw-r--r--app-text/rfcutil/rfcutil-3.2.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild b/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..4ae42a883d16
--- /dev/null
+++ b/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild,v 1.1 2011/12/13 20:22:37 jer Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_PN="rfc"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="return all related RFCs based upon a number or a search string"
+HOMEPAGE="http://www.dewn.com/rfc/"
+SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ || ( www-client/lynx virtual/w3m )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${MY_P}.diff \
+ "${FILESDIR}"/${MY_P}-index.patch
+}
+
+src_install() {
+ newbin ${MY_P} ${MY_PN}
+ doman ${MY_PN}.1
+ dodoc CHANGELOG KNOWN_BUGS README
+ keepdir /var/cache/rfc
+}
+
+pkg_postinst() {
+ elog "Gaarde suggests you make a cron.monthly to run the following:"
+ elog " /usr/bin/rfc -i"
+}
+
+pkg_prerm() {
+ rm -f "${ROOT}"/var/cache/rfc/*
+}