summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-05-15 05:30:30 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-05-15 05:30:30 +0000
commit5b65a6af5aa6a949ef3237ccdebca74a10fc4311 (patch)
tree02be7deca86d3eb398cfde726515692f77a30eec /app-text/sword
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-5b65a6af5aa6a949ef3237ccdebca74a10fc4311.tar.gz
gentoo-2-5b65a6af5aa6a949ef3237ccdebca74a10fc4311.tar.bz2
gentoo-2-5b65a6af5aa6a949ef3237ccdebca74a10fc4311.zip
Fix building with GCC 4.4. Thanks to Kent Fredric for the patch. (bug
#269190) (Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/ChangeLog9
-rw-r--r--app-text/sword/files/sword-1.5.11-gcc44.patch10
-rw-r--r--app-text/sword/sword-1.5.11.ebuild12
3 files changed, 26 insertions, 5 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index b0b8972e00a6..c5c31607b286 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sword
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.50 2009/02/26 15:41:41 josejx Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.51 2009/05/15 05:30:29 dirtyepic Exp $
+
+ 15 May 2009; Ryan Hill <dirtyepic@gentoo.org> sword-1.5.11.ebuild,
+ +files/sword-1.5.11-gcc44.patch:
+ Fix building with GCC 4.4. Thanks to Kent Fredric for the patch. (bug
+ #269190)
26 Feb 2009; Joseph Jezak <josejx@gentoo.org> sword-1.5.11.ebuild:
Marked ppc stable for bug #245855.
diff --git a/app-text/sword/files/sword-1.5.11-gcc44.patch b/app-text/sword/files/sword-1.5.11-gcc44.patch
new file mode 100644
index 000000000000..c2dd3d0fa706
--- /dev/null
+++ b/app-text/sword/files/sword-1.5.11-gcc44.patch
@@ -0,0 +1,10 @@
+--- sword-1.5.11-orig/utilities/emptyvss.cpp
++++ sword-1.5.11/utilities/emptyvss.cpp
+@@ -2,6 +2,7 @@
+ #include <swmodule.h>
+ #include <versekey.h>
+ #include <iostream>
++#include <cstdio>
+
+ #ifndef NO_SWORD_NAMESPACE
+ using sword::SWMgr;
diff --git a/app-text/sword/sword-1.5.11.ebuild b/app-text/sword/sword-1.5.11.ebuild
index c345166bfcff..6006912f0177 100644
--- a/app-text/sword/sword-1.5.11.ebuild
+++ b/app-text/sword/sword-1.5.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.11.ebuild,v 1.4 2009/02/26 15:41:41 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.11.ebuild,v 1.5 2009/05/15 05:30:29 dirtyepic Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="Library for Bible reading software."
HOMEPAGE="http://www.crosswire.org/sword/"
@@ -20,6 +20,12 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc44.patch #269190
+}
+
src_compile() {
strip-flags
econf --with-zlib \
@@ -32,7 +38,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die "install failed"
dodoc AUTHORS CODINGSTYLE ChangeLog INSTALL README
if use doc ;then
rm -rf examples/.cvsignore