summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-04-14 21:59:24 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-04-14 21:59:24 +0000
commitfeb44939ae574646a1eef836a483840d2402ba79 (patch)
tree1fd5a873e16653de2073d0b5aa8aa87367c82694 /app-text/xchm
parentRemove sliped inherit base from the previous fixing breakage :[ (diff)
downloadgentoo-2-feb44939ae574646a1eef836a483840d2402ba79.tar.gz
gentoo-2-feb44939ae574646a1eef836a483840d2402ba79.tar.bz2
gentoo-2-feb44939ae574646a1eef836a483840d2402ba79.zip
Version bump.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xchm')
-rw-r--r--app-text/xchm/ChangeLog9
-rw-r--r--app-text/xchm/xchm-1.15.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/app-text/xchm/ChangeLog b/app-text/xchm/ChangeLog
index 151677a0d6b1..9f73aaf5e727 100644
--- a/app-text/xchm/ChangeLog
+++ b/app-text/xchm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xchm
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.6 2008/06/19 03:21:38 dirtyepic Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.7 2009/04/14 21:59:24 dirtyepic Exp $
+
+*xchm-1.15 (14 Apr 2009)
+
+ 14 Apr 2009; Ryan Hill <dirtyepic@gentoo.org> +xchm-1.15.ebuild:
+ Version bump.
19 Jun 2008; Ryan Hill <dirtyepic@gentoo.org>
-files/xchm-1.13-gcc-4.3.patch, -xchm-1.13.ebuild, -xchm-1.13-r1.ebuild:
diff --git a/app-text/xchm/xchm-1.15.ebuild b/app-text/xchm/xchm-1.15.ebuild
new file mode 100644
index 000000000000..b1190e8d5d1a
--- /dev/null
+++ b/app-text/xchm/xchm-1.15.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/xchm-1.15.ebuild,v 1.1 2009/04/14 21:59:24 dirtyepic Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets flag-o-matic fdo-mime gnome2-utils
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="nls"
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:2.8"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ econf ${myconf} \
+ $(use_enable nls) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}