summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 10:05:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 10:05:48 +0000
commit36123b8961b1fa318aeaa5aee263a3572d89efd6 (patch)
treecad2d80d2ab697b40a1448bff6152e9067a81b61 /app-text/xml2doc
parentFix yesterdays typing error for libmpd versioning. (diff)
downloadgentoo-2-36123b8961b1fa318aeaa5aee263a3572d89efd6.tar.gz
gentoo-2-36123b8961b1fa318aeaa5aee263a3572d89efd6.tar.bz2
gentoo-2-36123b8961b1fa318aeaa5aee263a3572d89efd6.zip
Cleanup ebuild and fix build with --as-needed, thanks to Kevin Pyle in bug #247001.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/ChangeLog9
-rw-r--r--app-text/xml2doc/xml2doc-20030510-r1.ebuild27
2 files changed, 22 insertions, 14 deletions
diff --git a/app-text/xml2doc/ChangeLog b/app-text/xml2doc/ChangeLog
index 0b32e1cdcae7..65502eb19d90 100644
--- a/app-text/xml2doc/ChangeLog
+++ b/app-text/xml2doc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xml2doc
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/ChangeLog,v 1.17 2007/03/14 20:17:41 leonardop Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/ChangeLog,v 1.18 2009/06/02 10:05:48 flameeyes Exp $
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ xml2doc-20030510-r1.ebuild:
+ Cleanup ebuild and fix build with --as-needed, thanks to Kevin Pyle in bug
+ #247001.
*xml2doc-20030510-r1 (14 Mar 2007)
diff --git a/app-text/xml2doc/xml2doc-20030510-r1.ebuild b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
index 94ec1193fb4a..fc18e6521b17 100644
--- a/app-text/xml2doc/xml2doc-20030510-r1.ebuild
+++ b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/xml2doc-20030510-r1.ebuild,v 1.2 2007/07/12 04:37:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/xml2doc-20030510-r1.ebuild,v 1.3 2009/06/02 10:05:48 flameeyes Exp $
inherit eutils
@@ -28,29 +28,32 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-pointer_fix.patch"
# Don't strip symbols from binary (bug #152266)
- sed -i -e '/^\s*strip/d' src/Makefile.in
+ sed -i -e '/^\s*strip/d' \
+ -e '/^CC=/d' \
+ -e 's/^\t$(CC) $(LFLAGS).*/\t$(LINK.o) $(L_PDF) $^ -lxml2 -o $(BIN)/' \
+ -e '/^\t$(CC) $(CFLAGS) /d' \
+ src/Makefile.in
}
src_compile() {
- local myconf="$(use_enable pdf)"
-
- econf $myconf || die "./configure failed"
+ econf $(use_enable pdf) || die "./configure failed"
emake || die "Compilation failed"
+
+ cd "${S}/doc"
+ "${S}"/src/xml2doc -oM manpage.xml xml2doc.1 || die
}
src_install() {
# xml2doc's make install is unfortunately broken
# binary
- dobin ${S}/src/xml2doc
+ dobin src/xml2doc || die
# documentation
- dodoc BUGS README TODO
+ dodoc BUGS README TODO || die
docinto examples
- dodoc ${S}/examples/*.{xml,png}
+ dodoc examples/*.{xml,png} || die
# manpage
- cd ${S}/doc
- ${S}/src/xml2doc -oM manpage.xml xml2doc.1
- doman xml2doc.1
+ doman doc/xml2doc.1 || die
}