summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
commit3b400917584ce927f27df4cf507cc5630759f143 (patch)
treec5148d0abb45f9c45a2fd8ad233dcda899e8da92 /app-text
parent*** empty log message *** (diff)
downloadgentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.gz
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.bz2
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.zip
*** empty log message ***
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dsssl/dsssl-db-1.56.ebuild41
-rw-r--r--app-text/dsssl/files/digest-dsssl-db-1.561
-rw-r--r--app-text/ghostscript/files/all-arch.mak4
-rw-r--r--app-text/ghostscript/files/digest-ghostscript-6.232
-rw-r--r--app-text/ghostscript/ghostscript-6.23.ebuild68
5 files changed, 114 insertions, 2 deletions
diff --git a/app-text/dsssl/dsssl-db-1.56.ebuild b/app-text/dsssl/dsssl-db-1.56.ebuild
new file mode 100644
index 000000000000..e0549c6fdb21
--- /dev/null
+++ b/app-text/dsssl/dsssl-db-1.56.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/dsssl/dsssl-db-1.56.ebuild,v 1.1 2000/08/25 15:10:22 achim Exp $
+
+P=dsssl-db-1.56
+A=db156.zip
+S=${WORKDIR}/${P}
+DESCRIPTION="DSSSL stylesheets fot DocBook DTD"
+SRC_URI="http://nwalsh.com/docbook/dsssl/"${A}
+HOMEPAGE="http://www.nwalsh.com/docbook/dsssl/index.html"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unzip ${DISTDIR}/${A}
+}
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+ cd ${S}/docbook
+ into /usr
+ chmod +x bin/collateindex.pl
+ dobin bin/collateindex.pl
+ insinto /usr/share/sgml/stylesheets/docbook
+ doins docbook.dcl catalog
+ for i in common contrib dtds frames html images lib olink print
+ do
+ cp -af $i ${D}/usr/share/sgml/stylesheets/docbook
+ done
+ dodoc BUGS ChangeLog README TODO VERSION WhatsNew
+ cp -af test ${D}/usr/doc/${PF}
+
+}
+
+
+
+
diff --git a/app-text/dsssl/files/digest-dsssl-db-1.56 b/app-text/dsssl/files/digest-dsssl-db-1.56
new file mode 100644
index 000000000000..1e900b986447
--- /dev/null
+++ b/app-text/dsssl/files/digest-dsssl-db-1.56
@@ -0,0 +1 @@
+MD5 aeeb8502e78afd5f46fe34258732aa97 db156.zip
diff --git a/app-text/ghostscript/files/all-arch.mak b/app-text/ghostscript/files/all-arch.mak
index b786d1b09757..472556badef5 100644
--- a/app-text/ghostscript/files/all-arch.mak
+++ b/app-text/ghostscript/files/all-arch.mak
@@ -15,7 +15,7 @@
# License requires that the copyright notice and this notice be preserved on
# all copies.
-# $Id: all-arch.mak,v 1.1 2000/08/07 15:35:01 achim Exp $
+# $Id: all-arch.mak,v 1.2 2000/08/25 15:10:22 achim Exp $
#
# Author:
# Nelson H. F. Beebe
@@ -249,7 +249,7 @@ TARGETS =
#=======================================================================
-BINDIR = /usr/local/bin
+BINDIR = /usr/bin
CHMOD = chmod
diff --git a/app-text/ghostscript/files/digest-ghostscript-6.23 b/app-text/ghostscript/files/digest-ghostscript-6.23
new file mode 100644
index 000000000000..1a24e5d4968f
--- /dev/null
+++ b/app-text/ghostscript/files/digest-ghostscript-6.23
@@ -0,0 +1,2 @@
+MD5 6872883a40a560273ea046873412e7c4 ghostscript-6.23.tar.gz
+MD5 8250132d6fcc6eb1419f505f06c7690b ghostscript-fonts-std-6.0.tar.gz
diff --git a/app-text/ghostscript/ghostscript-6.23.ebuild b/app-text/ghostscript/ghostscript-6.23.ebuild
new file mode 100644
index 000000000000..9f215cdefda3
--- /dev/null
+++ b/app-text/ghostscript/ghostscript-6.23.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-6.23.ebuild,v 1.1 2000/08/25 15:10:22 achim Exp $
+
+P=ghostscript-6.23
+A="${P}.tar.gz ghostscript-fonts-std-6.0.tar.gz"
+A1=jpegsrc.v6b.tar.gz
+A2=zlib-1.1.3.tar.gz
+A3=libpng-1.0.6.tar.gz
+
+S=${WORKDIR}/gs6.23
+DESCRIPTION="Aladin Ghostscript"
+SRC_URI="http://download.sourceforge.net/ghostscript/${P}.tar.gz
+ http://download.sourceforge.net/gs-fonts/ghostscript-fonts-std-6.0.tar.gz"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir zlib
+ cd zlib
+ unpack ${A2}
+ cd ..
+ mkdir jpeg
+ cd jpeg
+ unpack ${A1}
+ cd ..
+ mkdir libpng
+ cd libpng
+ unpack ${A3}
+ cd ../src
+ cp ${O}/files/all-arch.mak all-arch.mak
+
+}
+
+src_compile() {
+ cd ${S}/src
+ cp all-arch.mak all-arch.mak.orig
+ sed -e "s:^SRCDIR.*:SRCDIR = ${S}:" all-arch.mak.orig > all-arch.mak
+ cp unix-gcc.mak unix-gcc.mak.orig
+ sed -e "s:-O2:${CFLAGS}:" unix-gcc.mak.orig > unix-gcc.mak
+ cd ..
+ make -f src/all-arch.mak linux prefix=/usr
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/bin
+ make -f src/all-arch.mak prefix=${D}/usr install
+ cd ${WORKDIR}
+ cp -a fonts ${D}/usr/share/ghostscript
+ cd ${S}
+
+ prepman
+
+ dodir /usr/doc/${PF}
+ rm -rf ${D}/usr/share/ghostscript/6.23/doc
+ dodoc doc/README doc/PUBLIC
+ docinto html
+ dodoc doc/*.html doc/*.htm
+ insinto /usr/share/emacs/site-lisp
+ doins doc/gsdoc.el
+
+}
+
+
+
+