summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-08 08:54:19 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-08 08:54:19 +0000
commit42a21504a670c20b4a5996a0063ffbc94a70caff (patch)
tree2314c05f4e49e299023dc5684d20ec40e6757ffe /app-text
parentVersion bump, see bug #63063. (Manifest recommit) (diff)
downloadgentoo-2-42a21504a670c20b4a5996a0063ffbc94a70caff.tar.gz
gentoo-2-42a21504a670c20b4a5996a0063ffbc94a70caff.tar.bz2
gentoo-2-42a21504a670c20b4a5996a0063ffbc94a70caff.zip
Don't unset C[XX]FLAGS. This closes bug #59514.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/openjade/ChangeLog5
-rw-r--r--app-text/openjade/openjade-1.3.2-r1.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/app-text/openjade/ChangeLog b/app-text/openjade/ChangeLog
index 99f7d2552fd1..b0253b3dd36b 100644
--- a/app-text/openjade/ChangeLog
+++ b/app-text/openjade/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/openjade
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/ChangeLog,v 1.36 2004/08/07 21:38:24 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/ChangeLog,v 1.37 2004/09/08 08:54:19 usata Exp $
+
+ 08 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> openjade-1.3.2-r1.ebuild:
+ Don't unset C[XX]FLAGS. This closes bug #59514.
07 Aug 2004; Tom Martin <slarti@gentoo.org> openjade-1.3.1-r5.ebuild,
openjade-1.3.1-r6.ebuild, openjade-1.3.2-r1.ebuild:
diff --git a/app-text/openjade/openjade-1.3.2-r1.ebuild b/app-text/openjade/openjade-1.3.2-r1.ebuild
index 02a4e8468c69..d7799da7c69b 100644
--- a/app-text/openjade/openjade-1.3.2-r1.ebuild
+++ b/app-text/openjade/openjade-1.3.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r1.ebuild,v 1.21 2004/08/07 21:38:24 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r1.ebuild,v 1.22 2004/09/08 08:54:19 usata Exp $
-inherit libtool sgml-catalog eutils
+inherit libtool sgml-catalog eutils flag-o-matic
DESCRIPTION="Jade is an implementation of DSSSL - an ISO standard for formatting SGML and XML documents"
HOMEPAGE="http://openjade.sourceforge.net"
@@ -29,15 +29,14 @@ src_compile() {
# Please note! Opts are disabled. If you know what you're doing
# feel free to remove this line. It may cause problems with
# docbook-sgml-utils among other things.
- CFLAGS=""
- CXXFLAGS=""
+ export ALLOWED_FLAGS="-O -O1 -O2 -pipe -g"
+ strip-flags
# Default CFLAGS and CXXFLAGS is -O2 but this make openjade segfault
# on hppa. Using -O1 works fine. So I force it here.
if [ "${ARCH}" = "hppa" ]
then
- CFLAGS="-O1 -pipe"
- CXXFLAGS="-O1 -pipe"
+ replace-flags -O[2] -O1
fi
ln -s config/configure.in configure.in
@@ -57,6 +56,7 @@ src_compile() {
src_install() {
dodir /usr
dodir /usr/lib
+
make prefix=${D}/usr \
datadir=${D}/usr/share/sgml/${P} \
install || die