summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-15 19:49:45 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-15 19:49:45 +0000
commit9153df9027686d64a7c32fc80b21904e2ae79932 (patch)
treed42b4668e78ad79a505eee7ba32d4c0f060513bc /app-text
parentAdd ruby20. (diff)
downloadgentoo-2-9153df9027686d64a7c32fc80b21904e2ae79932.tar.gz
gentoo-2-9153df9027686d64a7c32fc80b21904e2ae79932.tar.bz2
gentoo-2-9153df9027686d64a7c32fc80b21904e2ae79932.zip
EAPI=5. Drop ree18. Add ruby20.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ronn/ChangeLog7
-rw-r--r--app-text/ronn/ronn-0.7.3-r2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-text/ronn/ChangeLog b/app-text/ronn/ChangeLog
index 9ee3f365309e..4463f81f6a27 100644
--- a/app-text/ronn/ChangeLog
+++ b/app-text/ronn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/ronn
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.17 2013/07/16 07:35:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.18 2013/10/15 19:49:45 graaff Exp $
+
+*ronn-0.7.3-r2 (15 Oct 2013)
+
+ 15 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ronn-0.7.3-r2.ebuild:
+ EAPI=5. Drop ree18. Add ruby20.
16 Jul 2013; Hans de Graaff <graaff@gentoo.org> -ronn-0.7.3.ebuild:
Cleanup.
diff --git a/app-text/ronn/ronn-0.7.3-r2.ebuild b/app-text/ronn/ronn-0.7.3-r2.ebuild
new file mode 100644
index 000000000000..60941b0ddadd
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3-r2.ebuild,v 1.1 2013/10/15 19:49:45 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ronn converts simple, human readable textfiles to roff for terminal display, and also to HTML."
+HOMEPAGE="http://github.com/rtomayko/ronn/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+all_ruby_prepare() {
+ # Avoid test failing due to changes in hash handling in ruby 1.8.7:
+ # https://github.com/rtomayko/ronn/issues/56
+ sed -i -e '81 s:^:#:' test/test_ronn.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}