summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-15 11:11:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-15 11:11:44 +0000
commitb3e67589cf9aa2e71029f8562f755e9a20799f05 (patch)
tree54914711c8bd0791889320bef2e65e89a6cd3576 /app-text
parentbump to texlive 2015 version (diff)
downloadgentoo-2-b3e67589cf9aa2e71029f8562f755e9a20799f05.tar.gz
gentoo-2-b3e67589cf9aa2e71029f8562f755e9a20799f05.tar.bz2
gentoo-2-b3e67589cf9aa2e71029f8562f755e9a20799f05.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/teckit/ChangeLog9
-rw-r--r--app-text/teckit/teckit-2.5.3.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-text/teckit/ChangeLog b/app-text/teckit/ChangeLog
index ef25ca8ce79c..81980e798f53 100644
--- a/app-text/teckit/ChangeLog
+++ b/app-text/teckit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/teckit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/teckit/ChangeLog,v 1.24 2013/04/27 08:28:54 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/teckit/ChangeLog,v 1.25 2015/07/15 11:11:44 aballier Exp $
+
+*teckit-2.5.3 (15 Jul 2015)
+
+ 15 Jul 2015; Alexis Ballier <aballier@gentoo.org> +teckit-2.5.3.ebuild:
+ version bump
27 Apr 2013; Patrick Lauer <patrick@gentoo.org> teckit-2.5.1.ebuild:
Automake 1.13 fix
diff --git a/app-text/teckit/teckit-2.5.3.ebuild b/app-text/teckit/teckit-2.5.3.ebuild
new file mode 100644
index 000000000000..62239a7b539d
--- /dev/null
+++ b/app-text/teckit/teckit-2.5.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/teckit/teckit-2.5.3.ebuild,v 1.1 2015/07/15 11:11:44 aballier Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_P=TECkit_${PV}
+DESCRIPTION="Text Encoding Conversion toolkit"
+HOMEPAGE="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=TECkit"
+SRC_URI="http://scripts.sil.org/svn-view/teckit/TAGS/${MY_P}.tar.gz"
+
+LICENSE="|| ( CPL-0.5 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.5.1-mixcflagscxxflags.patch"
+ rm -f configure
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS
+}
+
+src_test() {
+ cd "${S}/test"
+ chmod +x dotests.pl
+ ./dotests.pl || die "tests failed"
+}