summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-02-11 22:14:53 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-02-11 22:14:53 +0000
commit730f695b5c067ac5578d98c1433e2cba077ba8ad (patch)
tree1d0b7c4caf2321411a9aa08248d725607de8e001 /app-vim/gentoo-syntax
parentGCC 4 compat fix, closes bug #81443. (diff)
downloadgentoo-2-730f695b5c067ac5578d98c1433e2cba077ba8ad.tar.gz
gentoo-2-730f695b5c067ac5578d98c1433e2cba077ba8ad.tar.bz2
gentoo-2-730f695b5c067ac5578d98c1433e2cba077ba8ad.zip
New release, mostly bugfixes. Arch detection code is now faster thanks to a cache, and should work properly on non-Linux. The thirdpartymirrors file should now be detected. ASFLAGS and ARCH are now shown as errors in make.conf. The runscript line in init.d files will now be created properly.
(Portage version: 2.0.51.16)
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/ChangeLog11
-rw-r--r--app-vim/gentoo-syntax/Manifest10
-rw-r--r--app-vim/gentoo-syntax/files/digest-gentoo-syntax-200502111
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20050211.ebuild52
4 files changed, 69 insertions, 5 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index c9c8daeff517..177295b5576b 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.33 2005/02/05 10:27:05 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.34 2005/02/11 22:14:53 ciaranm Exp $
+
+*gentoo-syntax-20050211 (11 Feb 2005)
+
+ 11 Feb 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +gentoo-syntax-20050211.ebuild:
+ New release, mostly bugfixes. Arch detection code is now faster thanks to a
+ cache, and should work properly on non-Linux. The thirdpartymirrors file
+ should now be detected. ASFLAGS and ARCH are now shown as errors in
+ make.conf. The runscript line in init.d files will now be created properly.
05 Feb 2005; Michael Hanselmann <hansmi@gentoo.org>
gentoo-syntax-20041227.ebuild:
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 090616cde809..ec93c366f52d 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,10 +1,12 @@
-MD5 a65dbc644b3668ff6544db0650a6b43f gentoo-syntax-20041009.ebuild 651
-MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 2f4abbfc45ac82a91635a4979651f093 gentoo-syntax-20050211.ebuild 1858
+MD5 2f4abbfc45ac82a91635a4979651f093 gentoo-syntax-20050130.ebuild 1858
MD5 14574ec8c2c927e92e21f756d1ddffd0 ChangeLog 6276
+MD5 a65dbc644b3668ff6544db0650a6b43f gentoo-syntax-20041009.ebuild 651
MD5 b36583dbb0ca97fc80fecf6767896467 gentoo-syntax-20041227.ebuild 1852
-MD5 2f4abbfc45ac82a91635a4979651f093 gentoo-syntax-20050130.ebuild 1858
+MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
MD5 a43ca03894628c098a86d47c8be49c9a gentoo-syntax-20041202.ebuild 1835
+MD5 4f56c7de174c5e2aef4d6217acbc46a3 files/digest-gentoo-syntax-20050211 74
MD5 c8e3ac5d8a31716f27516db1f6d138c9 files/digest-gentoo-syntax-20041227 74
MD5 06acc20457f894c7ca135be057b31ea4 files/digest-gentoo-syntax-20050130 74
-MD5 af854ba426622a145f3f786c605ff98c files/digest-gentoo-syntax-20041009 73
MD5 b5f329b0b88bc9f4ab39100919448b1f files/digest-gentoo-syntax-20041202 74
+MD5 af854ba426622a145f3f786c605ff98c files/digest-gentoo-syntax-20041009 73
diff --git a/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20050211 b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20050211
new file mode 100644
index 000000000000..dd4e9d63c411
--- /dev/null
+++ b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20050211
@@ -0,0 +1 @@
+MD5 c72df35c452ced76c2d5a92f4229affd gentoo-syntax-20050211.tar.bz2 16468
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20050211.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20050211.ebuild
new file mode 100644
index 000000000000..07ef64f4da3e
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20050211.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20050211.ebuild,v 1.1 2005/02/11 22:14:53 ciaranm Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage
+Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://developer.berlios.de/projects/gentoo-syntax"
+LICENSE="vim"
+KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc ~ppc64 ~alpha ~ia64 ~arm ~hppa ~s390"
+SRC_URI="http://download.berlios.de/gentoo-syntax/${P}.tar.bz2"
+
+# For gathering stats. Evil, I know, but I need to know whether I can
+# reasonably add this package in as a PDEPEND of vim-core. -- ciaranm
+RESTRICT="primaryuri"
+
+IUSE="ignore-glep31"
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ einfo "Note for developers and anyone else who edits ebuilds:"
+ einfo " This release of gentoo-syntax now contains filetype rules to set"
+ einfo " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ einfo " If you find this feature breaks things, please submit a bug and"
+ einfo " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ einfo " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}
+