summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-07-11 17:52:14 +0000
committerTim Harder <radhermit@gentoo.org>2013-07-11 17:52:14 +0000
commit21437913f06048625501514ebc03cb76bbcff865 (patch)
treedb34645d7af27aee925b3ff253d2b1db1b07c096 /app-vim/gundo
parentFix target directories causing configure failure wrt bug #476552. (diff)
downloadgentoo-2-21437913f06048625501514ebc03cb76bbcff865.tar.gz
gentoo-2-21437913f06048625501514ebc03cb76bbcff865.tar.bz2
gentoo-2-21437913f06048625501514ebc03cb76bbcff865.zip
Version bump, migrate to python-single-r1.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim/gundo')
-rw-r--r--app-vim/gundo/ChangeLog9
-rw-r--r--app-vim/gundo/gundo-2.5.0.ebuild25
2 files changed, 32 insertions, 2 deletions
diff --git a/app-vim/gundo/ChangeLog b/app-vim/gundo/ChangeLog
index c7955612c513..236bd9be0007 100644
--- a/app-vim/gundo/ChangeLog
+++ b/app-vim/gundo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/gundo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gundo/ChangeLog,v 1.8 2012/08/03 10:00:13 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gundo/ChangeLog,v 1.9 2013/07/11 17:52:14 radhermit Exp $
+
+*gundo-2.5.0 (11 Jul 2013)
+
+ 11 Jul 2013; Tim Harder <radhermit@gentoo.org> +gundo-2.5.0.ebuild:
+ Version bump, migrate to python-single-r1.
03 Aug 2012; Tim Harder <radhermit@gentoo.org> -gundo-2.2.0.ebuild,
-gundo-2.2.1.ebuild:
diff --git a/app-vim/gundo/gundo-2.5.0.ebuild b/app-vim/gundo/gundo-2.5.0.ebuild
new file mode 100644
index 000000000000..9df62f5b7768
--- /dev/null
+++ b/app-vim/gundo/gundo-2.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gundo/gundo-2.5.0.ebuild,v 1.1 2013/07/11 17:52:14 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: visualize your Vim undo tree"
+HOMEPAGE="http://sjl.bitbucket.org/gundo.vim/"
+SRC_URI="https://github.com/sjl/gundo.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="|| ( app-editors/vim[${PYTHON_USEDEP}] app-editors/gvim[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${PN}.vim-${PV}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+}