summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2006-01-16 23:38:00 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2006-01-16 23:38:00 +0000
commitab39901b7aa183978588f0cbd7cf4da892477d3d (patch)
tree430a36031b8164275f7af7731b3daa3dc8a2ec84 /app-vim/locateopen/locateopen-1.3.ebuild
parentMarked stable on x86 (diff)
downloadgentoo-2-ab39901b7aa183978588f0cbd7cf4da892477d3d.tar.gz
gentoo-2-ab39901b7aa183978588f0cbd7cf4da892477d3d.tar.bz2
gentoo-2-ab39901b7aa183978588f0cbd7cf4da892477d3d.zip
New version, with rlocate support that might actually work. Bug #119151.
(paludis 0.1.0 svn 107:108)
Diffstat (limited to 'app-vim/locateopen/locateopen-1.3.ebuild')
-rw-r--r--app-vim/locateopen/locateopen-1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/locateopen/locateopen-1.3.ebuild b/app-vim/locateopen/locateopen-1.3.ebuild
new file mode 100644
index 000000000000..44cab16e7946
--- /dev/null
+++ b/app-vim/locateopen/locateopen-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/locateopen/locateopen-1.3.ebuild,v 1.1 2006/01/16 23:38:00 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open a file without supplying a path"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=858"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} || ( sys-apps/slocate sys-apps/rlocate )"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides commands that hook vim into slocate:
+\ :LocateEdit filename
+\ :LocateSplit filename
+\ :LocateSource filename
+\ :LocateRead filename
+To configure:
+\ :let g:locateopen_ignorecase = 1 \" enable ignore case mode
+\ :let g:locateopen_smartcase = 0 \" disable smart case mode
+\ :let g:locateopen_alwaysprompt = 1 \" show menu for one match"