summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-20 04:59:08 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-20 04:59:08 +0000
commit2e502f1fa5be0b1abfd44efa0a58c608840dab70 (patch)
treeeae918b5ed48393920b6f85354e57a0f8bef724a /app-vim
parentSync prefix keywords. (diff)
downloadgentoo-2-2e502f1fa5be0b1abfd44efa0a58c608840dab70.tar.gz
gentoo-2-2e502f1fa5be0b1abfd44efa0a58c608840dab70.tar.bz2
gentoo-2-2e502f1fa5be0b1abfd44efa0a58c608840dab70.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/syntastic/ChangeLog7
-rw-r--r--app-vim/syntastic/syntastic-3.4.0.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/app-vim/syntastic/ChangeLog b/app-vim/syntastic/ChangeLog
index 6e99f3783ddd..6e6f8e5672f9 100644
--- a/app-vim/syntastic/ChangeLog
+++ b/app-vim/syntastic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/syntastic
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/syntastic/ChangeLog,v 1.8 2014/01/22 22:50:02 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/syntastic/ChangeLog,v 1.9 2014/03/20 04:59:08 radhermit Exp $
+
+*syntastic-3.4.0 (20 Mar 2014)
+
+ 20 Mar 2014; Tim Harder <radhermit@gentoo.org> +syntastic-3.4.0.ebuild:
+ Version bump.
*syntastic-3.3.0 (22 Jan 2014)
diff --git a/app-vim/syntastic/syntastic-3.4.0.ebuild b/app-vim/syntastic/syntastic-3.4.0.ebuild
new file mode 100644
index 000000000000..eec01e40d2ef
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/syntastic/syntastic-3.4.0.ebuild,v 1.1 2014/03/20 04:59:08 radhermit Exp $
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="WTFPL-2"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}