summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-28 19:17:48 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-28 19:17:48 +0000
commitaae35bc02eb43a73b820fced8f1b0eb77aad53fe (patch)
treea547e6c41b5d41479348a6d42e7076bf4af24bda /app-vim
parentAppend MAKEOPTS instead. (diff)
downloadgentoo-2-aae35bc02eb43a73b820fced8f1b0eb77aad53fe.tar.gz
gentoo-2-aae35bc02eb43a73b820fced8f1b0eb77aad53fe.tar.bz2
gentoo-2-aae35bc02eb43a73b820fced8f1b0eb77aad53fe.zip
Version bump.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/python-mode/ChangeLog9
-rw-r--r--app-vim/python-mode/python-mode-0.6.18.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/app-vim/python-mode/ChangeLog b/app-vim/python-mode/ChangeLog
index b574b95b94cf..95dc8e1aaf08 100644
--- a/app-vim/python-mode/ChangeLog
+++ b/app-vim/python-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/python-mode
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/ChangeLog,v 1.5 2012/11/12 10:07:46 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/ChangeLog,v 1.6 2013/05/28 19:17:48 radhermit Exp $
+
+*python-mode-0.6.18 (28 May 2013)
+
+ 28 May 2013; Tim Harder <radhermit@gentoo.org> +python-mode-0.6.18.ebuild:
+ Version bump.
*python-mode-0.6.10 (12 Nov 2012)
diff --git a/app-vim/python-mode/python-mode-0.6.18.ebuild b/app-vim/python-mode/python-mode-0.6.18.ebuild
new file mode 100644
index 000000000000..76a7801fe8eb
--- /dev/null
+++ b/app-vim/python-mode/python-mode-0.6.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/python-mode-0.6.18.ebuild,v 1.1 2013/05/28 19:17:48 radhermit Exp $
+
+EAPI=5
+
+VIM_PLUGIN_MESSAGES="filetype"
+VIM_PLUGIN_HELPFILES="PythonModeCommands"
+VIM_PLUGIN_HELPURI="https://github.com/klen/python-mode"
+
+inherit vim-plugin
+
+DESCRIPTION="Provide python code looking for bugs, refactoring and other useful things"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3770 https://github.com/klen/python-mode"
+SRC_URI="https://github.com/klen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/astng
+ dev-python/autopep8
+ dev-python/pyflakes
+ dev-python/pylint
+ dev-python/rope
+ dev-python/ropemode
+ "
+
+src_prepare() {
+ rm -rf pylibs/{logilab,*pep8.py,pyflakes,pylint,rope,ropemode} .gitignore
+ mv pylint.ini "${T}" || die
+ sed -e "s|expand(\"<sfile>:p:h:h\")|\"${EPREFIX}/usr/share/${PN}\"|" \
+ -i autoload/pymode.vim || die # use custom path
+ sed -e "s/pylibs.autopep8/autopep8/g" -i pylibs/pymode/auto.py || die
+ sed -e "s/pylibs.ropemode/ropemode/g" -i pylibs/ropevim.py || die
+}
+
+src_install() {
+ vim-plugin_src_install
+ insinto usr/share/${PN}
+ doins "${T}"/pylint.ini
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ einfo "If you use custom pylintrc make sure you append the contents of"
+ einfo " ${EPREFIX}/usr/share/${PN}/pylint.ini"
+ einfo "to it. Otherwise PyLint command will not work properly."
+}