summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-03-28 20:01:47 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-03-28 20:01:47 +0000
commitec65e0d4afb89e39110d002c696b96129bdd955c (patch)
tree4b8b45cb48f2d7ff2d7d478a1781363539c2e54b /app-vim
parentInitial import (Manifest recommit) (diff)
downloadgentoo-2-ec65e0d4afb89e39110d002c696b96129bdd955c.tar.gz
gentoo-2-ec65e0d4afb89e39110d002c696b96129bdd955c.tar.bz2
gentoo-2-ec65e0d4afb89e39110d002c696b96129bdd955c.zip
bump, #46013
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimcommander/ChangeLog8
-rw-r--r--app-vim/vimcommander/Manifest2
-rw-r--r--app-vim/vimcommander/files/digest-vimcommander-1.54.2.21
-rw-r--r--app-vim/vimcommander/vimcommander-1.54.2.2.ebuild30
4 files changed, 40 insertions, 1 deletions
diff --git a/app-vim/vimcommander/ChangeLog b/app-vim/vimcommander/ChangeLog
index e1e2d00e29ed..b16a8f1dd18c 100644
--- a/app-vim/vimcommander/ChangeLog
+++ b/app-vim/vimcommander/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/vimcommander
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/ChangeLog,v 1.2 2004/03/15 20:03:47 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/ChangeLog,v 1.3 2004/03/28 20:01:47 ciaranm Exp $
+
+*vimcommander-1.54.2.2 (28 Mar 2004)
+
+ 28 Mar 2004; Ciaran McCreesh <ciaranm@gentoo.org>
+ vimcommander-1.54.2.2.ebuild:
+ Version bump, thanks to Daniel Webert in bug #46013
15 Mar 2004; Ciaran McCreesh <ciaranm@gentoo.org> vimcommander-1.52.ebuild:
Stable on sparc
diff --git a/app-vim/vimcommander/Manifest b/app-vim/vimcommander/Manifest
index 0089b58da90a..240665f5f417 100644
--- a/app-vim/vimcommander/Manifest
+++ b/app-vim/vimcommander/Manifest
@@ -1,4 +1,6 @@
+MD5 08d6f2aea4e5113dd2edd378bf8b09e7 vimcommander-1.54.2.2.ebuild 1067
MD5 e4db4d5d76130cb6ca9c119acb79a7a7 ChangeLog 467
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
MD5 961da4480f6fd476016b02ad645cdaf7 vimcommander-1.52.ebuild 1063
MD5 9331dceeec76a6e442a160e310679f07 files/digest-vimcommander-1.52 68
+MD5 4e2da61fa5055a0218337f1af9921c8a files/digest-vimcommander-1.54.2.2 72
diff --git a/app-vim/vimcommander/files/digest-vimcommander-1.54.2.2 b/app-vim/vimcommander/files/digest-vimcommander-1.54.2.2
new file mode 100644
index 000000000000..23fc34b72c37
--- /dev/null
+++ b/app-vim/vimcommander/files/digest-vimcommander-1.54.2.2
@@ -0,0 +1 @@
+MD5 7d3345c71315b69194c58269ffa82731 vimcommander-1.54.2.2.tar.bz2 8833
diff --git a/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild b/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild
new file mode 100644
index 000000000000..7a6264562803
--- /dev/null
+++ b/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild,v 1.1 2004/03/28 20:01:47 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Total Commander style file explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=808"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~sparc ~x86"
+
+function src_unpack() {
+ unpack ${A}
+ mkdir ${S}/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic documentation install' trick. This
+ # causes problems for us during the unmerge. Fortunately, sed can fix
+ # this for us.
+ sed -e '1,/^=== START_DOC$/d' \
+ -e '/^=== END_DOC/,$d' \
+ -e "s/#version#/v${PV}/" \
+ ${S}/plugin/vimcommander.vim > ${S}/doc/vimcommander.txt \
+ || die "help extraction failed"
+
+ echo -ne "\n\n vim:tw=78:ts=8:ft=help:norl:" >> ${S}/doc/vimcommander.txt
+
+ sed -i -e 's/" \(let b:vimcommander_install_doc=\)[01]/\10/' \
+ ${S}/plugin/vimcommander.vim \
+ || die "help extract disable failed"
+}