summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2007-02-27 12:27:14 +0000
committerGeorge Shapovalov <george@gentoo.org>2007-02-27 12:27:14 +0000
commit0970885d62fff56d05cbdfa633f0ff391badc4cb (patch)
treee0c865c7347e5897ace6161ca8f20743430b9df5 /dev-ada/asis-gcc
parentdepend on baselibs-10.2 because giflib if provided there; bug 168501 (diff)
downloadgentoo-2-0970885d62fff56d05cbdfa633f0ff391badc4cb.tar.gz
gentoo-2-0970885d62fff56d05cbdfa633f0ff391badc4cb.tar.bz2
gentoo-2-0970885d62fff56d05cbdfa633f0ff391badc4cb.zip
backported gnatmake related fix from 4.1.2
(Portage version: 2.1.2-r12)
Diffstat (limited to 'dev-ada/asis-gcc')
-rw-r--r--dev-ada/asis-gcc/ChangeLog5
-rw-r--r--dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild41
-rw-r--r--dev-ada/asis-gcc/asis-gcc-4.1.1.ebuild41
3 files changed, 54 insertions, 33 deletions
diff --git a/dev-ada/asis-gcc/ChangeLog b/dev-ada/asis-gcc/ChangeLog
index 1e5745025255..59b78fa46aa5 100644
--- a/dev-ada/asis-gcc/ChangeLog
+++ b/dev-ada/asis-gcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ada/asis-gcc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/ChangeLog,v 1.6 2007/02/27 11:49:07 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/ChangeLog,v 1.7 2007/02/27 12:27:14 george Exp $
+
+ 27 Feb 2007; George Shapovalov <george@gentoo.org> asis-gcc-4.1.1.ebuild, asis-gcc-3.4.6.ebuild:
+ backported gnatmake related fix from 4.1.2
*asis-gcc-4.1.2-r1 (27 Feb 2007)
diff --git a/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild b/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild
index 7d3e9837558c..7480e47bb593 100644
--- a/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild
+++ b/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild,v 1.3 2007/01/25 23:41:35 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild,v 1.4 2007/02/27 12:27:14 george Exp $
inherit eutils flag-o-matic gnatbuild
@@ -34,6 +34,12 @@ QA_EXECSTACK="usr/lib/gnat-gcc/*/${SLOT}/adalib/libasis-${SLOT}.so
# it may be even better to force plain -O2 -pipe -ftracer here
replace-flags -O3 -O2
+# we need to adjust some vars defined in gnatbuild.eclass so that they use
+# gnat-gcc instead of asis
+My_LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
+My_BINPATH=${BINPATH/${PN}/${Gnat_Name}}
+My_DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
+
pkg_setup() {
currGnat=$(eselect --no-color gnat show | grep "gnat-" | awk '{ print $1 }')
@@ -48,6 +54,15 @@ pkg_setup() {
echo
die
fi
+ if [[ -e ${My_LIBPATH}/adalib/libasis.a ]] ; then
+ echo
+ ewarn "gnatmake of gnat-gcc unfortunately has problems forcind the build"
+ ewarn "if the package is already installed."
+ eerror "Please unmerge asis-gcc first and then resume the merge:"
+ eerror "emerge --unmerge asis-gcc && emerge asis-gcc"
+ echo
+ die
+ fi
}
src_unpack() {
@@ -93,41 +108,35 @@ src_compile() {
src_install () {
- # we need to adjust some vars defined in gnatbuild.eclass so that they use
- # gnat-gcc instead of asis
- LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
- BINPATH=${BINPATH/${PN}/${Gnat_Name}}
- DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
# install the lib
- dodir ${LIBPATH}/adalib
+ dodir ${My_LIBPATH}/adalib
chmod 0755 lib_dyn/libasis.so
- cp lib_dyn/libasis.so ${D}${LIBPATH}/adalib/libasis-${SLOT}.so
- insinto ${LIBPATH}/adalib
+ cp lib_dyn/libasis.so ${D}${My_LIBPATH}/adalib/libasis-${SLOT}.so
+ insinto ${My_LIBPATH}/adalib
doins obj/*.ali
doins lib/libasis.a
# make appropriate symlinks
- pushd ${D}${LIBPATH}/adalib
+ pushd ${D}${My_LIBPATH}/adalib
ln -s libasis-${SLOT}.so libasis.so
popd
# sources
- insinto ${LIBPATH}/adainclude
+ insinto ${My_LIBPATH}/adainclude
doins gnat/*.ad[sb]
doins asis/*.ad[sb]
# tools
- mkdir -p ${D}${BINPATH}
+ mkdir -p ${D}${My_BINPATH}
for fn in tools/{adabrowse,asistant,gnatelim,gnatstub}; do
- cp ${fn}/${fn:6} ${D}${BINPATH}
+ cp ${fn}/${fn:6} ${D}${My_BINPATH}
done
- cp tools/semtools/ada{dep,subst} ${D}${BINPATH}
+ cp tools/semtools/ada{dep,subst} ${D}${My_BINPATH}
if use doc; then
# docs and examples
dodoc documentation/*.{txt,ps}
dohtml documentation/*.html
# info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
+ insinto ${My_DATAPATH}/info/
doins documentation/*.info
fi
diff --git a/dev-ada/asis-gcc/asis-gcc-4.1.1.ebuild b/dev-ada/asis-gcc/asis-gcc-4.1.1.ebuild
index 54fcbe5ee28e..ec4a27837082 100644
--- a/dev-ada/asis-gcc/asis-gcc-4.1.1.ebuild
+++ b/dev-ada/asis-gcc/asis-gcc-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/asis-gcc-4.1.1.ebuild,v 1.3 2007/01/25 23:41:35 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/asis-gcc-4.1.1.ebuild,v 1.4 2007/02/27 12:27:14 george Exp $
inherit eutils flag-o-matic gnatbuild
@@ -34,6 +34,12 @@ QA_EXECSTACK="usr/lib/gnat-gcc/*/${SLOT}/adalib/libasis-4.1.so
# it may be even better to force plain -O2 -pipe -ftracer here
replace-flags -O3 -O2
+# we need to adjust some vars defined in gnatbuild.eclass so that they use
+# gnat-gcc instead of asis
+My_LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
+My_BINPATH=${BINPATH/${PN}/${Gnat_Name}}
+My_DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
+
pkg_setup() {
currGnat=$(eselect --no-color gnat show | grep "gnat-" | awk '{ print $1 }')
@@ -48,6 +54,15 @@ pkg_setup() {
echo
die
fi
+ if [[ -e ${My_LIBPATH}/adalib/libasis.a ]] ; then
+ echo
+ ewarn "gnatmake of gnat-gcc unfortunately has problems forcind the build"
+ ewarn "if the package is already installed."
+ eerror "Please unmerge asis-gcc first and then resume the merge:"
+ eerror "emerge --unmerge asis-gcc && emerge asis-gcc"
+ echo
+ die
+ fi
}
# we need to avoid calling gnatboot_src_unpack
@@ -101,41 +116,35 @@ src_compile() {
src_install () {
- # we need to adjust some vars defined in gnatbuild.eclass so that they use
- # gnat-gcc instead of asis
- LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
- BINPATH=${BINPATH/${PN}/${Gnat_Name}}
- DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
# install the lib
- dodir ${LIBPATH}/adalib
+ dodir ${My_LIBPATH}/adalib
chmod 0755 lib_dyn/libasis.so
- cp lib_dyn/libasis.so ${D}${LIBPATH}/adalib/libasis-${SLOT}.so
- insinto ${LIBPATH}/adalib
+ cp lib_dyn/libasis.so ${D}${My_LIBPATH}/adalib/libasis-${SLOT}.so
+ insinto ${My_LIBPATH}/adalib
doins obj/*.ali
doins lib/libasis.a
# make appropriate symlinks
- pushd ${D}${LIBPATH}/adalib
+ pushd ${D}${My_LIBPATH}/adalib
ln -s libasis-${SLOT}.so libasis.so
popd
# sources
- insinto ${LIBPATH}/adainclude
+ insinto ${My_LIBPATH}/adainclude
doins gnat/*.ad[sb]
doins asis/*.ad[sb]
# tools
- mkdir -p ${D}${BINPATH}
+ mkdir -p ${D}${My_BINPATH}
for fn in tools/{adabrowse,gnatelim,gnatstub,gnatpp,gnatmetric}; do
- cp ${fn}/${fn:6} ${D}${BINPATH}
+ cp ${fn}/${fn:6} ${D}${My_BINPATH}
done
- cp tools/semtools/ada{dep,subst} ${D}${BINPATH}
+ cp tools/semtools/ada{dep,subst} ${D}${My_BINPATH}
# docs and examples
if use doc ; then
dodoc documentation/*.{txt,ps}
dohtml documentation/*.html
# info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
+ insinto ${My_DATAPATH}/info/
doins documentation/*.info
insinto /usr/share/doc/${PF}