summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2008-01-24 21:30:06 +0000
committerGeorge Shapovalov <george@gentoo.org>2008-01-24 21:30:06 +0000
commit2af9238b285df9dd313624cc972b3b021c1c16fb (patch)
treea971d4c7a5e55ea726864593914eac9795b7dee8 /dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild
parentVersion bump and remove old (diff)
downloadgentoo-2-2af9238b285df9dd313624cc972b3b021c1c16fb.tar.gz
gentoo-2-2af9238b285df9dd313624cc972b3b021c1c16fb.tar.bz2
gentoo-2-2af9238b285df9dd313624cc972b3b021c1c16fb.zip
fixed quotation issues, removed stale ebuild
(Portage version: 2.1.4)
Diffstat (limited to 'dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild')
-rw-r--r--dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild b/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild
index a67e42f25569..ca498c44d1bd 100644
--- a/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild
+++ b/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild,v 1.1 2007/09/14 13:23:24 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gpl/asis-gpl-4.1.3.2007-r2.ebuild,v 1.2 2008/01/24 21:30:06 george Exp $
inherit eutils flag-o-matic gnatbuild
@@ -53,7 +53,7 @@ pkg_setup() {
# and change gcc to gnatgcc where appropriate
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
for fn in asis/a4g-gnat_int.adb gnat/snames.adb \
tools/tool_utils/asis_ul-common.adb \
tools/gnatmetric/metrics-compute.adb; do
@@ -84,13 +84,13 @@ src_compile() {
src_install () {
# install the lib
- mkdir -p ${D}${LIBPATH}/adalib
+ mkdir -p "${D}${LIBPATH}"/adalib
chmod 0755 obj/libasis-${ACT_Ver}.so
- cp obj/libasis-${ACT_Ver}.so ${D}${LIBPATH}/adalib
+ cp obj/libasis-${ACT_Ver}.so "${D}${LIBPATH}"/adalib
insinto ${LIBPATH}/adalib
doins obj/*.ali lib/libasis.a
# make appropriate symlinks
- pushd ${D}${LIBPATH}/adalib
+ pushd "${D}${LIBPATH}"/adalib
ln -s libasis-${ACT_Ver}.so libasis.so
popd
# sources
@@ -99,9 +99,9 @@ src_install () {
doins asis/*.ad[sb]
# tools
- mkdir -p ${D}${BINPATH}
+ mkdir -p "${D}${BINPATH}"
for fn in tools/{asistant,gnat*}; do
- cp ${fn}/${fn:6} ${D}${BINPATH}
+ cp ${fn}/${fn:6} "${D}${BINPATH}"
done
# docs and examples