summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-11-14 22:13:26 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-11-14 22:13:26 +0000
commit806e31f67b1bf151039a8fe6f9e235086fe1ae40 (patch)
tree2e3b85577da2249b05f30dfc5e3b6a58951390d9 /dev-ada/cbind/files
parentcbind6 was broken, no reason to keep it in the tree when new version is essen... (diff)
downloadgentoo-2-806e31f67b1bf151039a8fe6f9e235086fe1ae40.tar.gz
gentoo-2-806e31f67b1bf151039a8fe6f9e235086fe1ae40.tar.bz2
gentoo-2-806e31f67b1bf151039a8fe6f9e235086fe1ae40.zip
cbind6 was broken, no reason to keep it in the tree when new version is essentially the same and works
(Portage version: 2.1.2_rc1-r5) (Unsigned Manifest commit)
Diffstat (limited to 'dev-ada/cbind/files')
-rw-r--r--dev-ada/cbind/files/cbind6.diff300
-rw-r--r--dev-ada/cbind/files/digest-cbind-63
2 files changed, 0 insertions, 303 deletions
diff --git a/dev-ada/cbind/files/cbind6.diff b/dev-ada/cbind/files/cbind6.diff
deleted file mode 100644
index 7eb212151d39..000000000000
--- a/dev-ada/cbind/files/cbind6.diff
+++ /dev/null
@@ -1,300 +0,0 @@
-diff -Naur cbind6.orig/Makefile cbind6/Makefile
---- cbind6.orig/Makefile 2005-04-23 12:10:05.490371464 +0200
-+++ cbind6/Makefile 2005-04-23 12:10:18.803347584 +0200
-@@ -91,8 +91,11 @@
-
- install: all
- - strip cbpp cbfe cbind cdep
-- - rm -f $(HOME)/bin/cbpp $(HOME)/bin/cbfe $(HOME)/bin/cbind $(HOME)/bin/cdep
-- - cp cbpp cbfe cbind cdep $(HOME)/bin
-+ - rm -f $(PREFIX)/bin/cbpp $(PREFIX)/bin/cbfe $(PREFIX)/bin/cbind $(PREFIX)/bin/cdep
-+ - install -D cbpp $(PREFIX)/bin/cbpp
-+ - install -D cbfe $(PREFIX)/bin/cbfe
-+ - install -D cbind $(PREFIX)/bin/cbind
-+ - install -D cdep $(PREFIX)/bin/cdep
-
-
-
-@@ -132,14 +135,14 @@
- mkmf -f $(MAKEFILE)
-
- backup:
-- - rm -f $(HOME)/save/newc2a.tar.Z
-- tar -chf $(HOME)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
-- compress $(HOME)/save/newc2a.tar
-+ - rm -f $(PREFIX)/save/newc2a.tar.Z
-+ tar -chf $(PREFIX)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
-+ compress $(PREFIX)/save/newc2a.tar
-
- touch:; touch $(GENED_SRC)
-
- hostinfo.h: htype hostinfo
-- hostinfo $@
-+ ./hostinfo $@
-
- c_perf.c: c.prf
- gperf -N c_rsvd -t -p c.prf > $@
-diff -Naur cbind6.orig/allocate.c cbind6/allocate.c
---- cbind6.orig/allocate.c 2005-04-23 12:10:05.403384688 +0200
-+++ cbind6/allocate.c 2005-04-23 12:10:18.790349560 +0200
-@@ -4,7 +4,7 @@
- #include <sys/types.h>
- #include <unistd.h>
- #include <string.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include "ansi.h"
- #include "config.h"
- #include "allocate.h"
-diff -Naur cbind6.orig/buffer.c cbind6/buffer.c
---- cbind6.orig/buffer.c 2005-04-23 12:10:05.405384384 +0200
-+++ cbind6/buffer.c 2005-04-23 12:10:18.792349256 +0200
-@@ -5,7 +5,7 @@
- */
-
- #include <sys/types.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include "ansi.h"
- #include "buffer.h"
- #include "allocate.h"
-diff -Naur cbind6.orig/cbind.c cbind6/cbind.c
---- cbind6.orig/cbind.c 2005-04-23 12:10:05.417382560 +0200
-+++ cbind6/cbind.c 2005-04-23 12:10:18.793349104 +0200
-@@ -6,7 +6,7 @@
- #include <sys/types.h>
- #include <string.h>
- #include <unistd.h>
--#include <malloc.h>
-+#include <stdlib.h>
-
- #undef NULL
- #define NULL 0
-diff -Naur cbind6.orig/cdep.c cbind6/cdep.c
---- cbind6.orig/cdep.c 2005-04-23 12:10:05.419382256 +0200
-+++ cbind6/cdep.c 2005-04-23 12:10:18.794348952 +0200
-@@ -12,6 +12,7 @@
- #include "cpp.h"
- #include "cpp_hide.h"
- #include "allocate.h"
-+#include "host.h"
-
- #undef NULL
- #define NULL 0
-diff -Naur cbind6.orig/errors.c cbind6/errors.c
---- cbind6.orig/errors.c 2005-04-23 12:10:05.422381800 +0200
-+++ cbind6/errors.c 2005-04-23 12:10:57.882406664 +0200
-@@ -1,6 +1,7 @@
- #include <stdio.h>
--#include <varargs.h>
-+#include <stdarg.h>
- #include <errno.h>
-+#include <string.h>
-
- int Num_Errors;
- int Num_Warnings;
-@@ -33,14 +34,11 @@
- }
-
- void
--fatal(f, l, fmt, va_alist)
-- char *f, *fmt;
-- int l;
-- va_dcl
-+fatal(char *f, int l, const char *fmt, ...)
- {
- va_list args;
-
-- va_start(args);
-+ va_start(args,fmt);
-
- prefix(f,l,"Internal error");
- vfprintf(stderr, fmt, args);
-@@ -52,14 +50,11 @@
- }
-
- void
--error(f, l, fmt, va_alist)
-- char *f, *fmt;
-- int l;
-- va_dcl
-+error(char *f, int l, char *fmt, ...)
- {
- va_list args;
-
-- va_start(args);
-+ va_start(args,fmt);
-
- Num_Errors++;
- prefix(f,l,"Error");
-@@ -70,14 +65,11 @@
- }
-
- void
--warning(f, l, fmt, va_alist)
-- char *f, *fmt;
-- int l;
-- va_dcl
-+warning(char *f, int l, char *fmt, ...)
- {
- va_list args;
-
-- va_start(args);
-+ va_start(args,fmt);
-
- Num_Warnings++;
- prefix(f,l,"Warning");
-@@ -88,14 +80,11 @@
- }
-
- void
--inform(f, l, fmt, va_alist)
-- char *f, *fmt;
-- int l;
-- va_dcl
-+inform(char *f, int l, char *fmt, ...)
- {
- va_list args;
-
-- va_start(args);
-+ va_start(args,fmt);
-
- prefix(f,l,"Info");
- vfprintf(stderr, fmt, args);
-@@ -118,12 +107,9 @@
- static void
- unix_error()
- {
-- extern char *sys_errlist[];
-- extern int sys_nerr;
--
- if (errno != 0) {
-- if (errno > 0 && errno < sys_nerr) {
-- fputs(sys_errlist[errno], stderr);
-+ if (errno > 0) {
-+ fputs(strerror(errno), stderr);
- }
- else {
- fprintf(stderr, "errno = %d", errno);
-diff -Naur cbind6.orig/files.c cbind6/files.c
---- cbind6.orig/files.c 2005-04-23 12:10:05.422381800 +0200
-+++ cbind6/files.c 2005-04-23 12:10:18.797348496 +0200
-@@ -1,5 +1,6 @@
- #include "ansi.h"
- #include "hostinfo.h"
-+#include "host.h"
- #include "config.h"
-
- #include <sys/types.h>
-@@ -11,7 +12,7 @@
- #include <sys/mman.h>
- #else
- #include <unistd.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #endif
-
- #undef NULL
-diff -Naur cbind6.orig/hostinfo cbind6/hostinfo
---- cbind6.orig/hostinfo 2005-04-23 12:10:05.489371616 +0200
-+++ cbind6/hostinfo 2005-04-23 12:10:18.798348344 +0200
-@@ -4,25 +4,10 @@
-
- echo '/* This file is automatically generated */' > $1
- echo '#define _H_HOSTINFO_' >> $1
--htype >> $1
--
--cat > llchk.c << _STOP
--main()
--{
-- struct s {
-- char c;
-- long long x;
-- };
-- printf("\n#define SIZEOF_LONG_LONG\t\t%d\n", sizeof(long long));
-- printf("#define ALIGNOF_LONG_LONG\t\t%d\n\n",
-- sizeof(char) + ((sizeof(struct s) - (sizeof(char)+sizeof(long long)))));
--}
--_STOP
-+./htype >> $1
-
- cc llchk.c >& /dev/null
- if ($status == 0) a.out >> $1
--rm -f a.out
--rm -f llchk.c
-
- echo '#define HOST_OS '`uname` >> $1
-
-diff -Naur cbind6.orig/htype.c cbind6/htype.c
---- cbind6.orig/htype.c 2005-04-23 12:10:05.447378000 +0200
-+++ cbind6/htype.c 2005-04-23 12:10:18.801347888 +0200
-@@ -132,10 +132,14 @@
- printf("\n#define CHARS_ARE_%sSIGNED\n", (((char)-1) < 0) ? "" : "UN");
-
- if (*p == 1) {
-+ puts("#ifndef BIG_ENDIAN");
- puts("#define BIG_ENDIAN");
-+ puts("#endif");
- }
- else {
-+ puts("#ifndef LITTLE_ENDIAN");
- puts("#define LITTLE_ENDIAN");
-+ puts("#endif");
- }
-
- return 0;
-diff -Naur cbind6.orig/llchk.c cbind6/llchk.c
---- cbind6.orig/llchk.c 1970-01-01 01:00:00.000000000 +0100
-+++ cbind6/llchk.c 2005-04-23 12:10:18.802347736 +0200
-@@ -0,0 +1,13 @@
-+
-+main()
-+{
-+ struct s {
-+ char c;
-+ long long x;
-+ };
-+ printf("\n#define SIZEOF_LONG_LONG\t\t%d\n", sizeof(long long));
-+ printf("#define ALIGNOF_LONG_LONG\t\t%d\n\n",
-+ sizeof(char) + ((sizeof(struct s) - (sizeof(char)+sizeof(long long)))));
-+}
-+
-+
-diff -Naur cbind6.orig/nodeop.c cbind6/nodeop.c
---- cbind6.orig/nodeop.c 2005-04-23 12:10:05.449377696 +0200
-+++ cbind6/nodeop.c 2005-04-23 12:11:30.862392944 +0200
-@@ -1,5 +1,5 @@
- #include <sys/types.h>
--#include <varargs.h>
-+#include <stdarg.h>
- #include <stdio.h>
- #include "ansi.h"
- #include "host.h"
-@@ -85,14 +85,12 @@
- }
-
- node_t*
--new_node(kind, va_alist)
-- node_kind_t kind;
-- va_dcl
-+new_node(node_kind_t kind, ...)
- {
- va_list args;
- node_t *n;
-
-- va_start(args);
-+ va_start(args, kind);
-
- n = alloc_node(kind);
-
-diff -Naur cbind6.orig/units.c cbind6/units.c
---- cbind6.orig/units.c 2005-04-23 12:10:05.453377088 +0200
-+++ cbind6/units.c 2005-04-23 12:10:18.804347432 +0200
-@@ -2,6 +2,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <stdio.h>
-+#include "host.h"
- #include "ansi.h"
- #include "files.h"
- #include "units.h"
diff --git a/dev-ada/cbind/files/digest-cbind-6 b/dev-ada/cbind/files/digest-cbind-6
deleted file mode 100644
index ce3d3b9ba4d6..000000000000
--- a/dev-ada/cbind/files/digest-cbind-6
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 250a2db4799376d3586070c175d6c279 cbind6.zip 101939
-RMD160 86ad6a10cbac865a4d13a19041b98e2a65fd36cf cbind6.zip 101939
-SHA256 206566d6981a100b7a9b0b7006eb87e6f11f5665a2ff97c6a917250b42d0b3ff cbind6.zip 101939