summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2007-05-25 20:49:26 +0000
committerGeorge Shapovalov <george@gentoo.org>2007-05-25 20:49:26 +0000
commit40a695034ae0a04a4d094f87562259fafb17844c (patch)
tree8ef73dd76aa6fdabbf2f99a8fd36bb2f28e4dd3f /dev-ada
parentinitial commit. (diff)
downloadgentoo-2-40a695034ae0a04a4d094f87562259fafb17844c.tar.gz
gentoo-2-40a695034ae0a04a4d094f87562259fafb17844c.tar.bz2
gentoo-2-40a695034ae0a04a4d094f87562259fafb17844c.zip
added new version to match gnat-2007
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/asis-gpl/ChangeLog8
-rw-r--r--dev-ada/asis-gpl/asis-gpl-4.1.3.2007.ebuild121
-rw-r--r--dev-ada/asis-gpl/files/digest-asis-gpl-4.1.3.20073
3 files changed, 131 insertions, 1 deletions
diff --git a/dev-ada/asis-gpl/ChangeLog b/dev-ada/asis-gpl/ChangeLog
index d8767e1a983c..0bf3ed0b4fa2 100644
--- a/dev-ada/asis-gpl/ChangeLog
+++ b/dev-ada/asis-gpl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ada/asis-gpl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gpl/ChangeLog,v 1.2 2007/01/25 23:43:15 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gpl/ChangeLog,v 1.3 2007/05/25 20:49:26 george Exp $
+
+*asis-gpl-4.1.3.2007 (25 May 2007)
+
+ 25 May 2007; user account for gentoo cvs access <portage-cvs@gentoo.org>
+ +asis-gpl-4.1.3.2007.ebuild:
+ added new version to match gnat-2007
25 Jan 2007; Marius Mauch <genone@gentoo.org> asis-gpl-3.4.6.2006.ebuild:
Replacing einfo with elog
diff --git a/dev-ada/asis-gpl/asis-gpl-4.1.3.2007.ebuild b/dev-ada/asis-gpl/asis-gpl-4.1.3.2007.ebuild
new file mode 100644
index 000000000000..187ca91de1a1
--- /dev/null
+++ b/dev-ada/asis-gpl/asis-gpl-4.1.3.2007.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gpl/asis-gpl-4.1.3.2007.ebuild,v 1.1 2007/05/25 20:49:26 george Exp $
+
+inherit eutils flag-o-matic gnatbuild
+
+ACT_Ver=$(get_version_component_range 4)
+Gnat_Name="gnat-gpl"
+
+DESCRIPTION="The Ada Semantic Interface Specification (semantic analysis and tools tied to compiler)"
+SRC_URI="http://dev.gentoo.org/~george/src/${PN}-${ACT_Ver}-src.tgz"
+HOMEPAGE="https://libre.adacore.com/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+
+
+IUSE="doc"
+RDEPEND="=dev-lang/gnat-gpl-${PV}*"
+DEPEND="${RDEPEND}
+ doc? ( virtual/tetex
+ app-text/texi2html )"
+
+S="${WORKDIR}/asis-${ACT_Ver}-src"
+
+
+# it may be even better to force plain -O2 -pipe -ftracer here
+replace-flags -O3 -O2
+
+# we need to adjust some vars defined in gnatbuild.eclass so that they use
+# gnat-gpl instead of asis
+LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
+BINPATH=${BINPATH/${PN}/${Gnat_Name}}
+DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
+
+QA_EXECSTACK="${BINPATH:1}/*
+ ${LIBPATH:1}/adalib/libasis-${ACT_Ver}.so"
+
+
+pkg_setup() {
+ currGnat=$(eselect --no-color gnat show | grep "gnat-" | awk '{ print $1 }')
+ if [[ "${currGnat}" != "${CTARGET}-${Gnat_Name}-${SLOT}" ]]; then
+ echo
+ eerror "The active gnat profile does not correspond to the selected"
+ eerror "version of asis! Please install the appropriate gnat (if you"
+ eerror "did not so yet) and run:"
+ eerror "eselect gnat set ${CTARGET}-${Gnat_Name}-${SLOT}"
+ eerror "env-update && source /etc/profile"
+ eerror "and then emerge =dev-ada/${P} again.."
+ echo
+ die
+ fi
+}
+
+# we need to override the eclass defined src_unpack
+src_unpack() {
+ unpack ${A}
+}
+
+
+src_compile() {
+ # Build the shared library first, we need -fPIC here
+ gnatmake -Pasis_bld -XBLD=prod -XOPSYS=default_Unix -cargs ${CFLAGS} -fPIC \
+ || die "building libasis.a failed"
+ gnatgcc -shared -Wl,-soname,libasis-${ACT_Ver}.so \
+ -o obj/libasis-${ACT_Ver}.so obj/*.o -lc \
+ || die "building libasis.so failed"
+
+ # build tools
+ for fn in tools/*; do
+ pushd ${fn}
+ gnatmake -P${fn:6}.gpr || die "building ${fn:6} failed"
+ popd
+ done
+
+ # common stuff is just docs in this case
+ if use doc; then
+ emake -C documentation all || die "Failed while compiling documentation"
+ fi
+}
+
+
+src_install () {
+ # install the lib
+ mkdir -p ${D}${LIBPATH}/adalib
+ chmod 0755 obj/libasis-${ACT_Ver}.so
+ cp obj/libasis-${ACT_Ver}.so ${D}${LIBPATH}/adalib
+ insinto ${LIBPATH}/adalib
+ doins obj/*.ali lib/libasis.a
+ # make appropriate symlinks
+ pushd ${D}${LIBPATH}/adalib
+ ln -s libasis-${ACT_Ver}.so libasis.so
+ popd
+ # sources
+ insinto ${LIBPATH}/adainclude
+ doins gnat/*.ad[sb]
+ doins asis/*.ad[sb]
+
+ # tools
+ mkdir -p ${D}${BINPATH}
+ for fn in tools/{asistant,gnat*}; do
+ cp ${fn}/${fn:6} ${D}${BINPATH}
+ done
+
+ # docs and examples
+ dodoc documentation/*.txt
+ dohtml documentation/*.html
+ # info's should go into gnat-gpl dirs
+ insinto ${DATAPATH}/info/
+ doins documentation/*.info
+
+ insinto /usr/share/doc/${PF}
+ doins -r documentation/*.pdf examples/ tutorial/ templates/
+}
+
+pkg_postinst() {
+ echo
+ elog "The ASIS is installed for the active gnat compiler at gnat's location."
+ elog "No further configuration is necessary. Enjoy."
+ echo
+}
diff --git a/dev-ada/asis-gpl/files/digest-asis-gpl-4.1.3.2007 b/dev-ada/asis-gpl/files/digest-asis-gpl-4.1.3.2007
new file mode 100644
index 000000000000..c6d8e94b0ca4
--- /dev/null
+++ b/dev-ada/asis-gpl/files/digest-asis-gpl-4.1.3.2007
@@ -0,0 +1,3 @@
+MD5 051c9c956498bf020d031f9b769f3924 asis-gpl-2007-src.tgz 2268673
+RMD160 571d43d4ef719fdfd9e75e82901cc527ff1622b2 asis-gpl-2007-src.tgz 2268673
+SHA256 6b8f5d3372bcfa83a49e991550f8e7ecb66d3fc59cac3d1cbc835eee32da189b asis-gpl-2007-src.tgz 2268673