summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-24 14:12:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-24 14:12:48 +0000
commit09422133a6abec9a0f32d7a6e9d15b26f79e1430 (patch)
tree05bddcaae902bafd5c1f54bb471a67f256a34752 /dev-cpp/commoncpp2
parentInitial import for phctool (diff)
downloadgentoo-2-09422133a6abec9a0f32d7a6e9d15b26f79e1430.tar.gz
gentoo-2-09422133a6abec9a0f32d7a6e9d15b26f79e1430.tar.bz2
gentoo-2-09422133a6abec9a0f32d7a6e9d15b26f79e1430.zip
Fix building with recent glibc wrt #334135 by "kde at hilefoks.org" and Arttu Valo.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/commoncpp2')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog7
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild3
-rw-r--r--dev-cpp/commoncpp2/files/1.8.0-glibc212.patch12
3 files changed, 20 insertions, 2 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index e823f62a91a7..4252ee008615 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.53 2010/06/26 16:47:05 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.54 2010/08/24 14:12:48 ssuominen Exp $
+
+ 24 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +files/1.8.0-glibc212.patch, commoncpp2-1.8.0.ebuild:
+ Fix building with recent glibc wrt #334135 by "kde at hilefoks.org" and
+ Arttu Valo.
26 Jun 2010; Christoph Mende <angelos@gentoo.org> commoncpp2-1.8.0.ebuild:
Stable on amd64 wrt bug #321931
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild
index cb0f4d7b327a..903b9538ace3 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild,v 1.4 2010/06/26 16:47:05 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild,v 1.5 2010/08/24 14:12:48 ssuominen Exp $
EAPI="2"
inherit eutils autotools
@@ -23,6 +23,7 @@ DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
src_prepare() {
epatch "${FILESDIR}/1.6.1-gcc42_atomicity.patch"
epatch "${FILESDIR}/1.6.2-configure_detect_netfilter.patch" # bug 236177
+ epatch "${FILESDIR}/1.8.0-glibc212.patch"
eautoreconf
}
diff --git a/dev-cpp/commoncpp2/files/1.8.0-glibc212.patch b/dev-cpp/commoncpp2/files/1.8.0-glibc212.patch
new file mode 100644
index 000000000000..a29e154a20ee
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.8.0-glibc212.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/334135
+
+--- src/applog.cpp
++++ src/applog.cpp
+@@ -44,6 +44,7 @@
+ #include <cstdio>
+ #include <stdarg.h>
+ #include <errno.h>
++#include <sys/stat.h>
+
+ // TODO sc: test if has to move up now that it is into commoncpp
+ // NOTE: the order of inclusion is important do not move following include line