summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2014-01-12 06:34:39 +0000
committerRyan Hill <dirtyepic@gentoo.org>2014-01-12 06:34:39 +0000
commitb6c70ac5045f4a94dad8fa9a9423ef18e1663b9f (patch)
tree78045a37a9ed5a9b3560656581e8045762a5750e /dev-cpp/gmock
parentVersion bump. (diff)
downloadgentoo-2-b6c70ac5045f4a94dad8fa9a9423ef18e1663b9f.tar.gz
gentoo-2-b6c70ac5045f4a94dad8fa9a9423ef18e1663b9f.tar.bz2
gentoo-2-b6c70ac5045f4a94dad8fa9a9423ef18e1663b9f.zip
Version bump (bug #490406 by Jauhien Piatlicki).
Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'dev-cpp/gmock')
-rw-r--r--dev-cpp/gmock/ChangeLog9
-rw-r--r--dev-cpp/gmock/gmock-1.7.0.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-cpp/gmock/ChangeLog b/dev-cpp/gmock/ChangeLog
index 0f37d92cdb84..c8c903fea3b5 100644
--- a/dev-cpp/gmock/ChangeLog
+++ b/dev-cpp/gmock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/gmock
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/ChangeLog,v 1.17 2013/12/09 19:29:59 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/ChangeLog,v 1.18 2014/01/12 06:34:39 dirtyepic Exp $
+
+*gmock-1.7.0 (12 Jan 2014)
+
+ 12 Jan 2014; Ryan Hill <dirtyepic@gentoo.org> +gmock-1.7.0.ebuild:
+ Version bump (bug #490406 by Jauhien Piatlicki).
09 Dec 2013; Jeroen Roovers <jer@gentoo.org> gmock-1.6.0.ebuild:
Stable for HPPA (bug #493400).
diff --git a/dev-cpp/gmock/gmock-1.7.0.ebuild b/dev-cpp/gmock/gmock-1.7.0.ebuild
new file mode 100644
index 000000000000..d29598f2c2af
--- /dev/null
+++ b/dev-cpp/gmock/gmock-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.7.0.ebuild,v 1.1 2014/01/12 06:34:39 dirtyepic Exp $
+
+EAPI="4"
+
+inherit libtool
+
+DESCRIPTION="Google's C++ mocking framework"
+HOMEPAGE="http://code.google.com/p/googlemock/"
+SRC_URI="http://googlemock.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="=dev-cpp/gtest-${PV}*"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+src_unpack() {
+ default
+ # make sure we always use the system one
+ rm -r "${S}"/gtest/{Makefile,configure}* || die
+}
+
+src_prepare() {
+ sed -i -r \
+ -e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
+ Makefile.in
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dobin scripts/gmock-config
+ use static-libs || find "${D}" -name '*.la' -delete
+}