summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-05 13:55:14 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-05 13:55:14 +0000
commited70fcd0aa48613999265bbfc14b71d06b45aac9 (patch)
tree696ba1bb1b71a869b1c5729e5f473d394a946534 /dev-cpp/pstreams
parentdrop PAX_RANDKSTACK check, its not needed (diff)
downloadgentoo-2-ed70fcd0aa48613999265bbfc14b71d06b45aac9.tar.gz
gentoo-2-ed70fcd0aa48613999265bbfc14b71d06b45aac9.tar.bz2
gentoo-2-ed70fcd0aa48613999265bbfc14b71d06b45aac9.zip
Version Bump; bug #547860
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-cpp/pstreams')
-rw-r--r--dev-cpp/pstreams/ChangeLog11
-rw-r--r--dev-cpp/pstreams/metadata.xml8
-rw-r--r--dev-cpp/pstreams/pstreams-0.8.1.ebuild43
3 files changed, 55 insertions, 7 deletions
diff --git a/dev-cpp/pstreams/ChangeLog b/dev-cpp/pstreams/ChangeLog
index 21b0250d7bcf..8895fd270895 100644
--- a/dev-cpp/pstreams/ChangeLog
+++ b/dev-cpp/pstreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/pstreams
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/ChangeLog,v 1.4 2012/12/05 12:25:26 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/ChangeLog,v 1.5 2015/05/05 13:55:14 jlec Exp $
+
+*pstreams-0.8.1 (05 May 2015)
+
+ 05 May 2015; Justin Lecher <jlec@gentoo.org> +pstreams-0.8.1.ebuild,
+ metadata.xml:
+ Version Bump; bug #547860
05 Dec 2012; Justin Lecher <jlec@gentoo.org> pstreams-0.7.0.ebuild:
Install all docs correctly, #442982; bump to EAPI=5 and use doheader
@@ -19,4 +25,3 @@
18 May 2010; Justin Lecher <jlec@gentoo.org> +pstreams-0.7.0.ebuild,
+metadata.xml:
Initial addition
-
diff --git a/dev-cpp/pstreams/metadata.xml b/dev-cpp/pstreams/metadata.xml
index c1661663322e..7bc6ee8ea837 100644
--- a/dev-cpp/pstreams/metadata.xml
+++ b/dev-cpp/pstreams/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jlec@gentoo.org</email>
- <name>Justin Lecher</name>
- </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-cpp/pstreams/pstreams-0.8.1.ebuild b/dev-cpp/pstreams/pstreams-0.8.1.ebuild
new file mode 100644
index 000000000000..2e5afa104a0c
--- /dev/null
+++ b/dev-cpp/pstreams/pstreams-0.8.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/pstreams-0.8.1.ebuild,v 1.1 2015/05/05 13:55:14 jlec Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="C++ wrapper for the POSIX.2 functions popen(3) and pclose(3)"
+HOMEPAGE="http://pstreams.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}-docs-${PV}.tar.gz )"
+
+SLOT="0"
+LICENSE="LGPL-3"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_compile() {
+ if use doc; then
+ doxygen -u || die
+ emake
+ fi
+}
+
+src_test() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ check
+}
+
+src_install() {
+ doheader pstream.h
+
+ dodoc AUTHORS ChangeLog README
+
+ use doc && dohtml -r "${WORKDIR}"/${PN}-docs-${PV}/*
+}