summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-28 13:33:14 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-28 13:33:14 +0000
commit442ef564cac0f43948fd1f5a9eeb877acea589d1 (patch)
treee4cf482c69dba2f1ad01b7de13080a9387ada64a /dev-cpp/sparsehash
parentVersion bump to latest. Drop older. (diff)
downloadgentoo-2-442ef564cac0f43948fd1f5a9eeb877acea589d1.tar.gz
gentoo-2-442ef564cac0f43948fd1f5a9eeb877acea589d1.tar.bz2
gentoo-2-442ef564cac0f43948fd1f5a9eeb877acea589d1.zip
Fix for gcc46, Some cleanup QA of the ebuilds
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/sparsehash')
-rw-r--r--dev-cpp/sparsehash/ChangeLog6
-rw-r--r--dev-cpp/sparsehash/files/1.10-gcc46.patch16
-rw-r--r--dev-cpp/sparsehash/sparsehash-1.1.ebuild9
-rw-r--r--dev-cpp/sparsehash/sparsehash-1.10.ebuild18
-rw-r--r--dev-cpp/sparsehash/sparsehash-1.5.2.ebuild7
5 files changed, 36 insertions, 20 deletions
diff --git a/dev-cpp/sparsehash/ChangeLog b/dev-cpp/sparsehash/ChangeLog
index 58a4246042d8..472c49b95c88 100644
--- a/dev-cpp/sparsehash/ChangeLog
+++ b/dev-cpp/sparsehash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/sparsehash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/ChangeLog,v 1.6 2011/02/16 18:25:58 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/ChangeLog,v 1.7 2011/04/28 13:33:14 jlec Exp $
+
+ 28 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/1.10-gcc46.patch,
+ sparsehash-1.1.ebuild, sparsehash-1.5.2.ebuild, sparsehash-1.10.ebuild:
+ Fix for gcc46, Some cleanup QA of the ebuilds
*sparsehash-1.10 (16 Feb 2011)
diff --git a/dev-cpp/sparsehash/files/1.10-gcc46.patch b/dev-cpp/sparsehash/files/1.10-gcc46.patch
new file mode 100644
index 000000000000..4339b487eca0
--- /dev/null
+++ b/dev-cpp/sparsehash/files/1.10-gcc46.patch
@@ -0,0 +1,16 @@
+ src/google/sparsetable | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/google/sparsetable b/src/google/sparsetable
+index 0eeb22e..e8580b9 100644
+--- a/src/google/sparsetable
++++ b/src/google/sparsetable
+@@ -83,6 +83,8 @@
+ #endif
+ #endif
+
++#include <cstddef>
++
+ _START_GOOGLE_NAMESPACE_
+
+ #ifndef HAVE_U_INT16_T
diff --git a/dev-cpp/sparsehash/sparsehash-1.1.ebuild b/dev-cpp/sparsehash/sparsehash-1.1.ebuild
index f8ffc609bdbb..03955a62d4f8 100644
--- a/dev-cpp/sparsehash/sparsehash-1.1.ebuild
+++ b/dev-cpp/sparsehash/sparsehash-1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.1.ebuild,v 1.1 2008/03/07 19:02:16 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.1.ebuild,v 1.2 2011/04/28 13:33:14 jlec Exp $
-DESCRIPTION="An extremely memory-efficient hash_map implementation."
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
HOMEPAGE="http://code.google.com/p/google-sparsehash/"
SRC_URI="http://google-sparsehash.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
@@ -10,9 +10,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
-
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
diff --git a/dev-cpp/sparsehash/sparsehash-1.10.ebuild b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
index 49b176e7ee77..28aac64e6fdb 100644
--- a/dev-cpp/sparsehash/sparsehash-1.10.ebuild
+++ b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
@@ -1,26 +1,28 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.10.ebuild,v 1.1 2011/02/16 18:25:59 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.10.ebuild,v 1.2 2011/04/28 13:33:14 jlec Exp $
-EAPI="3"
+EAPI="4"
-DESCRIPTION="An extremely memory-efficient hash_map implementation."
+inherit eutils
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
HOMEPAGE="http://code.google.com/p/google-sparsehash/"
SRC_URI="http://google-sparsehash.googlecode.com/files/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc46.patch
+}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
# Installs just every piece
rm -rf "${D}/usr/share/doc"
-
- dodoc AUTHORS ChangeLog NEWS README TODO
dohtml doc/*
}
diff --git a/dev-cpp/sparsehash/sparsehash-1.5.2.ebuild b/dev-cpp/sparsehash/sparsehash-1.5.2.ebuild
index 7e83799c9864..f1c9cdd2f3a5 100644
--- a/dev-cpp/sparsehash/sparsehash-1.5.2.ebuild
+++ b/dev-cpp/sparsehash/sparsehash-1.5.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.5.2.ebuild,v 1.3 2011/02/11 13:04:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sparsehash/sparsehash-1.5.2.ebuild,v 1.4 2011/04/28 13:33:14 jlec Exp $
-DESCRIPTION="An extremely memory-efficient hash_map implementation."
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
HOMEPAGE="http://code.google.com/p/google-sparsehash/"
SRC_URI="http://google-sparsehash.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
@@ -10,9 +10,6 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
-
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"