summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-11-12 22:17:14 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-11-12 22:17:14 +0000
commit1728afccc06b06dfe33f1616eea2922c9dc1eba9 (patch)
tree45cc229aed748b20e58a21c4bcc89200c09fc14f /dev-cpp/tbb
parentmask games-simulation/openttd openmedia since the content generation tools ar... (diff)
downloadgentoo-2-1728afccc06b06dfe33f1616eea2922c9dc1eba9.tar.gz
gentoo-2-1728afccc06b06dfe33f1616eea2922c9dc1eba9.tar.bz2
gentoo-2-1728afccc06b06dfe33f1616eea2922c9dc1eba9.zip
Version bump
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/ChangeLog7
-rw-r--r--dev-cpp/tbb/tbb-4.2.20131003.ebuild127
2 files changed, 133 insertions, 1 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index 968ae55a7e37..a8db64c274bc 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.43 2013/08/27 20:20:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.44 2013/11/12 22:17:14 bicatali Exp $
+
+*tbb-4.2.20131003 (12 Nov 2013)
+
+ 12 Nov 2013; Sébastien Fabbro <bicatali@gentoo.org> +tbb-4.2.20131003.ebuild:
+ Version bump
27 Aug 2013; Alexis Ballier <aballier@gentoo.org> tbb-4.1.20130613.ebuild:
Fix shared lib installation on FreeBSD.
diff --git a/dev-cpp/tbb/tbb-4.2.20131003.ebuild b/dev-cpp/tbb/tbb-4.2.20131003.ebuild
new file mode 100644
index 000000000000..b956b4f305a6
--- /dev/null
+++ b/dev-cpp/tbb/tbb-4.2.20131003.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.2.20131003.ebuild,v 1.1 2013/11/12 22:17:14 bicatali Exp $
+
+EAPI=5
+inherit eutils flag-o-matic multilib versionator toolchain-funcs
+
+PV1="$(get_version_component_range 1)"
+PV2="$(get_version_component_range 2)"
+PV3="$(get_version_component_range 3)"
+MYP="${PN}${PV1}${PV2}_${PV3}oss"
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="http://www.threadingbuildingblocks.org/"
+SRC_URI="http://threadingbuildingblocks.org/sites/default/files/software_releases/source/${MYP}_src.tgz"
+LICENSE="GPL-2-with-exceptions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug doc examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.0.297-underlinking.patch
+ # use fully qualified gcc compilers. do not force march/mcpu
+ # not tested with icc
+ # order in sed expressions is important
+ sed -i \
+ -e "s/g++/$(tc-getCXX)/g" \
+ -e "s/gcc/$(tc-getCC)/g" \
+ -e 's/-m\(arch\|cpu\)=*[[:space:]]//g' \
+ -e 's/-\(m\|-\)\(64\|32\)//g' \
+ -e 's/-O2/$(CXXFLAGS)/g' \
+ -e "/^ASM/s/as/$(tc-getAS)/g" \
+ build/*.gcc.inc || die
+
+ # Give it a soname on FreeBSD
+ echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
+ # Set proper versionning on FreeBSD
+ sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
+
+ # force 64bit where applicable, 32bit where applicable...
+ # built-in detection is based on running kernel, which messes up
+ # e.g. in a x86 chroot on amd64 kernel. Bug 462130
+ # see build/linux.inc for values
+ use amd64 && export arch=x86_64
+ use amd64-linux && export arch=x86_64
+ use x86 && export arch=ia32
+ use x86-linux && export arch=ia32
+ # no idea what to do with ppc but so far it seems to work
+
+ find include -name \*.html -delete || die
+
+ # pc files are for debian and fedora compatibility
+ # some deps use them
+ cat <<-EOF > ${PN}.pc.template
+ prefix=${EPREFIX}/usr
+ libdir=\${prefix}/$(get_libdir)
+ includedir=\${prefix}/include
+ Name: ${PN}
+ Description: ${DESCRIPTION}
+ Version: ${PV}
+ URL: ${HOMEPAGE}
+ Cflags: -I\${includedir}
+ EOF
+ cp ${PN}.pc.template ${PN}.pc
+ cat <<-EOF >> ${PN}.pc
+ Libs: -L\${libdir} -ltbb
+ Libs.private: -lm -lrt
+ EOF
+ cp ${PN}.pc.template ${PN}malloc.pc
+ cat <<-EOF >> ${PN}malloc.pc
+ Libs: -L\${libdir} -ltbbmalloc
+ Libs.private: -lm -lrt
+ EOF
+ cp ${PN}.pc.template ${PN}malloc_proxy.pc
+ cat <<-EOF >> ${PN}malloc_proxy.pc
+ Libs: -L\${libdir} -ltbbmalloc_proxy
+ Libs.private: -lrt
+ Requires: tbbmalloc
+ EOF
+ use debug || sed -i -e '/_debug/d' Makefile
+}
+
+src_compile() {
+ if [[ $(tc-getCXX) == *g++ ]]; then
+ comp="gcc"
+ elif [[ $(tc-getCXX) == *ic*c ]]; then
+ comp="icc"
+ else
+ die "compiler $(tc-getCXX) not supported by build system"
+ fi
+ emake compiler=${comp} tbb tbbmalloc
+}
+
+src_test() {
+ append-cxxflags -fabi-version=4
+ # avoid oversubscribing with -j1
+ emake -j1 compiler=${comp} test
+}
+
+src_install(){
+ local l
+ for l in $(find build -name lib\*.so.\*); do
+ dolib.so ${l}
+ local bl=$(basename ${l})
+ dosym ${bl} /usr/$(get_libdir)/${bl%.*}
+ done
+ doheader -r include/*
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins *.pc
+
+ dodoc README CHANGES doc/Release_Notes.txt
+ use doc && dohtml -r doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples/build
+ doins build/*.inc
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples
+ fi
+}