summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-02-14 09:34:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-02-14 09:34:20 +0000
commite1f59c940d0240a9adb5b18b505b15b978b1c3ec (patch)
tree93fb5db0687c76d14d3a66ebe23713900f341cee /dev-cpp/tbb
parentversion bump (diff)
downloadgentoo-2-e1f59c940d0240a9adb5b18b505b15b978b1c3ec.tar.gz
gentoo-2-e1f59c940d0240a9adb5b18b505b15b978b1c3ec.tar.bz2
gentoo-2-e1f59c940d0240a9adb5b18b505b15b978b1c3ec.zip
Fix build on ppc.
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/files/tbb-4.1.20121003-ppc.patch16
-rw-r--r--dev-cpp/tbb/tbb-4.1.20121003.ebuild6
2 files changed, 20 insertions, 2 deletions
diff --git a/dev-cpp/tbb/files/tbb-4.1.20121003-ppc.patch b/dev-cpp/tbb/files/tbb-4.1.20121003-ppc.patch
new file mode 100644
index 000000000000..c50e051c3d38
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-4.1.20121003-ppc.patch
@@ -0,0 +1,16 @@
+diff -up tbb40_20120408oss/include/tbb/tbb_machine.h\~ tbb40_20120408oss/include/tbb/tbb_machine.h
+--- tbb40_20120408oss/include/tbb/tbb_machine.h~ 2012-04-20 09:21:57.000000000 +0200
++++ tbb40_20120408oss/include/tbb/tbb_machine.h 2012-08-28 13:20:42.150456167 +0200
+@@ -373,8 +373,8 @@ void spin_wait_until_eq( const volatile
+ // - The operation assumes that the architecture consistently uses either little-endian or big-endian:
+ // it does not support mixed-endian or page-specific bi-endian architectures.
+ // This function is the only use of __TBB_BIG_ENDIAN.
+-#if (__TBB_BIG_ENDIAN!=-1)
+- #if ( __TBB_USE_GENERIC_PART_WORD_CAS)
++#if ( __TBB_USE_GENERIC_PART_WORD_CAS)
++ #if (__TBB_BIG_ENDIAN==-1)
+ #error generic implementation of part-word CAS was explicitly disabled for this configuration
+ #endif
+ template<typename T>
+
+Diff finished. Tue Aug 28 13:20:58 2012
diff --git a/dev-cpp/tbb/tbb-4.1.20121003.ebuild b/dev-cpp/tbb/tbb-4.1.20121003.ebuild
index d9b66b590b3c..a09f2125ff5b 100644
--- a/dev-cpp/tbb/tbb-4.1.20121003.ebuild
+++ b/dev-cpp/tbb/tbb-4.1.20121003.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.1.20121003.ebuild,v 1.4 2013/02/06 04:26:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.1.20121003.ebuild,v 1.5 2013/02/14 09:34:20 scarabeus Exp $
EAPI=4
inherit eutils flag-o-matic multilib versionator toolchain-funcs
@@ -24,7 +24,9 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MYP}"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.0.297-underlinking.patch
+ epatch \
+ "${FILESDIR}"/${PN}-4.0.297-underlinking.patch \
+ "${FILESDIR}"/${PN}-4.1.20121003-ppc.patch
# use fully qualified gcc compilers. do not force march/mcpu
# not tested with icc
# order in sed expressions is important