summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-05-24 01:02:13 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-05-24 01:02:13 +0000
commit3544934daaaa4024412398a2a10dce5b23845013 (patch)
tree88bed745e62603aac1ae6a72bdd8aad17622f00f /dev-cpp
parentRemove old. (diff)
downloadgentoo-2-3544934daaaa4024412398a2a10dce5b23845013.tar.gz
gentoo-2-3544934daaaa4024412398a2a10dce5b23845013.tar.bz2
gentoo-2-3544934daaaa4024412398a2a10dce5b23845013.zip
Remove old.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog7
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild78
-rw-r--r--dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch63
-rw-r--r--dev-cpp/commoncpp2/files/1.6.2-configure_detect_netfilter.patch12
4 files changed, 6 insertions, 154 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 9b844c6d9d93..dad74e698f9c 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.63 2015/04/21 19:10:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.64 2015/05/24 01:02:13 mrueg Exp $
+
+ 24 May 2015; Manuel Rüger <mrueg@gentoo.org> -commoncpp2-1.8.0.ebuild,
+ -files/1.6.1-gcc42_atomicity.patch,
+ -files/1.6.2-configure_detect_netfilter.patch:
+ Remove old.
21 Apr 2015; Pacho Ramos <pacho@gentoo.org> commoncpp2-1.8.1-r1.ebuild:
ppc stable wrt bug #491974
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild
deleted file mode 100644
index d487cffa49fd..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild,v 1.7 2014/03/01 22:24:51 mgorny Exp $
-
-EAPI="2"
-inherit eutils autotools
-
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
-SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/commoncpp/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="debug doc examples ipv6 gnutls"
-
-RDEPEND="gnutls? ( dev-libs/libgcrypt:0
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- ${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/1.6.1-gcc42_atomicity.patch"
- epatch "${FILESDIR}/1.6.2-configure_detect_netfilter.patch" # bug 236177
- epatch "${FILESDIR}/1.8.0-glibc212.patch"
- eautoreconf
-}
-
-src_configure() {
- use doc || \
- sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
-
- local myconf
- if use gnutls; then
- myconf="--with-gnutls --without-openssl"
- else
- myconf="--without-gnutls --with-openssl"
- fi
-
- econf \
- $(use_enable debug) \
- $(use_with ipv6 ) \
- ${myconf}
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- cd demo
- doins *.cpp *.h *.xml README
- fi
-}
-
-pkg_postinst() {
- ewarn "There's a change in the ABI between version 1.5.x and 1.6.x, please"
- ewarn "run the following command to find broken packages and rebuild them:"
- ewarn " revdep-rebuild --library=libccext2-1.5.so"
-}
-
-# Some of the tests hang forever
-#src_test() {
-# cd "${S}/tests"
-# emake || die "emake tests failed"
-# ./test.sh || die "tests failed"
-#}
diff --git a/dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch b/dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch
deleted file mode 100644
index da30105f8cf4..000000000000
--- a/dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff -Naur commoncpp2-1.6.1.orig/m4/ost_pthread.m4 commoncpp2-1.6.1/m4/ost_pthread.m4
---- commoncpp2-1.6.1.orig/m4/ost_pthread.m4 2008-05-06 10:47:42.000000000 +0200
-+++ commoncpp2-1.6.1/m4/ost_pthread.m4 2008-05-06 16:11:05.000000000 +0200
-@@ -92,7 +92,9 @@
- dnl check for gcc's bits/atomicity and the atomic functions therein
- AC_CHECK_HEADERS([bits/atomicity.h],
- ost_cv_bits_atomicity=yes,
-- ost_cv_bits_atomicity=no)
-+ [AC_CHECK_HEADERS([ext/atomicity.h],
-+ ost_cv_bits_atomicity=yes,
-+ ost_cv_bits_atomicity=no)])
- if test $ost_cv_bits_atomicity = yes ; then
- AC_MSG_CHECKING([for _Atomic_word])
- AC_TRY_COMPILE([#include <bits/atomicity.h>],
-@@ -103,7 +105,15 @@
- ],
- [ost_cv_gcc_atomic=yes
- AC_DEFINE(HAVE_GCC_BITS_ATOMIC, [1], [has gcc atomic functions])],
-- [ost_cv_gcc_atomic=no])
-+ [AC_TRY_COMPILE([#include <ext/atomicity.h>],
-+ [
-+ _Atomic_word i = 0;
-+ __atomic_add(&i, 1);
-+ __exchange_and_add(&i, 1);
-+ ],
-+ [ost_cv_gcc_atomic=yes
-+ AC_DEFINE(HAVE_GCC_BITS_ATOMIC, [1], [has gcc atomic functions])],
-+ [ost_cv_gcc_atomic=no])])
- AC_MSG_RESULT($ost_cv_gcc_atomic)
-
- AC_MSG_CHECKING([for __gnu_cxx::_Atomic_word])
-@@ -117,7 +127,17 @@
- [ost_cv_gcc_cxx_atomic=yes
- AC_DEFINE(HAVE_GCC_CXX_BITS_ATOMIC, [1],
- [has __gnu_cxx atomic functions])],
-- [ost_cv_gcc_cxx_atomic=no])
-+ [AC_TRY_COMPILE([#include <ext/atomicity.h>],
-+ [
-+ using namespace __gnu_cxx;
-+ _Atomic_word i = 0;
-+ __atomic_add(&i, 1);
-+ __exchange_and_add(&i, 1);
-+ ],
-+ [ost_cv_gcc_cxx_atomic=yes
-+ AC_DEFINE(HAVE_GCC_CXX_BITS_ATOMIC, [1],
-+ [has __gnu_cxx atomic functions])],
-+ [ost_cv_gcc_cxx_atomic=no])])
- AC_MSG_RESULT($ost_cv_gcc_cxx_atomic)
- fi
-
-@@ -438,7 +458,11 @@
-
- #if defined(__cplusplus)
- #if defined(HAVE_GCC_BITS_ATOMIC) || defined(HAVE_GCC_CXX_BITS_ATOMIC)
--#include <bits/atomicity.h>
-+#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 2))
-+ #include <ext/atomicity.h>
-+#else
-+ #include <bits/atomicity.h>
-+#endif
- #define HAVE_ATOMIC
- #endif
- #endif
diff --git a/dev-cpp/commoncpp2/files/1.6.2-configure_detect_netfilter.patch b/dev-cpp/commoncpp2/files/1.6.2-configure_detect_netfilter.patch
deleted file mode 100644
index de532b51c3cf..000000000000
--- a/dev-cpp/commoncpp2/files/1.6.2-configure_detect_netfilter.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- m4/ost_socket.m4-orig 2008-11-16 15:24:05.000000000 +0100
-+++ m4/ost_socket.m4 2008-11-16 15:24:10.000000000 +0100
-@@ -95,6 +95,9 @@
- AC_CHECK_HEADERS([linux/netfilter_ipv4.h linux/netfilter_ipv6.h],,,
- [#ifdef HAVE_LIMITS_H
- #include <limits.h>
-+ #endif
-+ #ifdef HAVE_NETINET_IN_H
-+ #include <netinet/in.h>
- #endif])
- if test "$ac_cv_header_linux_netfilter_ipv4_h" = "yes" &&
- [ test "$ac_cv_header_linux_netfilter_ipv6_h" = "yes" &&