summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-02-17 20:09:11 +0000
committerJohannes Huber <johu@gentoo.org>2015-02-17 20:09:11 +0000
commit39abb24d4ed4fbc7644e72165444fd5df54e0f39 (patch)
tree804e48b517b705842835e6f9a421615e2afa679a /dev-cpp
parentActually clean out old versions. (diff)
downloadgentoo-2-39abb24d4ed4fbc7644e72165444fd5df54e0f39.tar.gz
gentoo-2-39abb24d4ed4fbc7644e72165444fd5df54e0f39.tar.bz2
gentoo-2-39abb24d4ed4fbc7644e72165444fd5df54e0f39.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/websocketpp/ChangeLog8
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.5.0.ebuild35
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-cpp/websocketpp/ChangeLog b/dev-cpp/websocketpp/ChangeLog
index b2dabd96c93c..a33d8ce1c6d7 100644
--- a/dev-cpp/websocketpp/ChangeLog
+++ b/dev-cpp/websocketpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/websocketpp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/websocketpp/ChangeLog,v 1.1 2015/01/16 23:24:06 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/websocketpp/ChangeLog,v 1.2 2015/02/17 20:09:11 johu Exp $
+
+*websocketpp-0.5.0 (17 Feb 2015)
+
+ 17 Feb 2015; Johannes Huber <johu@gentoo.org> +websocketpp-0.5.0.ebuild:
+ Version bump.
*websocketpp-0.4.0 (16 Jan 2015)
@@ -8,4 +13,3 @@
+metadata.xml:
New package. Initial ebuild by Uwe L. Korn <uwelk@xhochy.com>. Modified by
me. Bug #528764.
-
diff --git a/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
new file mode 100644
index 000000000000..7da8cb385573
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild,v 1.1 2015/02/17 20:09:11 johu Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost test"
+
+DEPEMD=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# tests no-op
+RESTRICT="test"
+
+src_configure() {
+ # Disable EXAMPLES as compilation is broken upstream
+ local mycmakeargs=(
+ -DEXAMPLES=OFF
+ $(cmake-utils_use_enable !boost CPP11)
+ $(cmake-utils_use_enable test TESTS)
+ )
+
+ cmake-utils_src_configure
+}