summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMeir Kriheili <mksoft@gentoo.org>2004-04-25 09:01:37 +0000
committerMeir Kriheili <mksoft@gentoo.org>2004-04-25 09:01:37 +0000
commite79f478c1009fc557836861f4b75de3dcc41eb1a (patch)
tree0c991f64b4e6d46f44ceecc67d24ee8affc1d48b /dev-db/firebird
parentMarked stable on mips. (Manifest recommit) (diff)
downloadgentoo-2-e79f478c1009fc557836861f4b75de3dcc41eb1a.tar.gz
gentoo-2-e79f478c1009fc557836861f4b75de3dcc41eb1a.tar.bz2
gentoo-2-e79f478c1009fc557836861f4b75de3dcc41eb1a.zip
moved firebird.log to /var/log and fixed localhost check in /etc/hosts.equiv
Diffstat (limited to 'dev-db/firebird')
-rw-r--r--dev-db/firebird/ChangeLog10
-rw-r--r--dev-db/firebird/firebird-1.5.0.ebuild21
2 files changed, 25 insertions, 6 deletions
diff --git a/dev-db/firebird/ChangeLog b/dev-db/firebird/ChangeLog
index e3fca71e9497..8add7c7d70b3 100644
--- a/dev-db/firebird/ChangeLog
+++ b/dev-db/firebird/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/firebird
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.14 2004/04/03 22:54:57 mksoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.15 2004/04/25 09:01:37 mksoft Exp $
+
+ 25 Apr 2004; <mksoft@gentoo.org> firebird-1.5.0.ebuild:
+ move and symlink firebird.log to /var/log
+
+ change the check the for localhost in /etc/hosts.equiv to make sure it
+ won't catch localhost.localdomain as well
+
+ unmask for x86
04 Apr 2004; <mksoft@gentoo.org> firebird-1.5.0.ebuild:
Modified classic local USE flag, changed to inetd
diff --git a/dev-db/firebird/firebird-1.5.0.ebuild b/dev-db/firebird/firebird-1.5.0.ebuild
index 324d34757187..eb45a51a1f4b 100644
--- a/dev-db/firebird/firebird-1.5.0.ebuild
+++ b/dev-db/firebird/firebird-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.0.ebuild,v 1.4 2004/04/08 23:07:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.0.ebuild,v 1.5 2004/04/25 09:01:37 mksoft Exp $
inherit flag-o-matic eutils
@@ -135,9 +135,20 @@ pkg_config() {
done
# Create log
- touch firebird.log
- chown firebird:firebird firebird.log
- chmod ug=rw,o= firebird.log
+ if [ ! -h firebird.log ]
+ then
+ if [ -f firebird.log ]
+ then
+ mv firebird.log /var/log
+ else
+ touch /var/log/firebird.log
+ chown firebird:firebird /var/log/firebird.log
+ chmod ug=rw,o= /var/log/firebird.log
+ fi
+
+ # symlink the log to /var/log
+ ln -s /var/log/firebird.log firebird.log
+ fi
# add gds_db to /etc/services
if [ -z "`grep gds_db /etc/services`" ]
@@ -180,7 +191,7 @@ pkg_config() {
chmod u=rw,go=r /etc/hosts.equiv
fi
- if [ -z "`grep localhost /etc/hosts.equiv`" ]
+ if [ -z "`grep 'localhost$' /etc/hosts.equiv`" ]
then
echo "localhost" >> /etc/hosts.equiv
einfo "Added localhost to /etc/hosts.equiv"