summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-03-04 13:19:02 +0000
committerMichael Imhof <tantive@gentoo.org>2004-03-04 13:19:02 +0000
commit90761eaf0a872e0f349d464b5ab415458a3e557e (patch)
treea3d896409c9a73e74e3f72ab4f386ccd99754fc1 /dev-db/libiodbc/libiodbc-3.51.2.ebuild
parentdep for gwine, bug 27301 (Manifest recommit) (diff)
downloadgentoo-2-90761eaf0a872e0f349d464b5ab415458a3e557e.tar.gz
gentoo-2-90761eaf0a872e0f349d464b5ab415458a3e557e.tar.bz2
gentoo-2-90761eaf0a872e0f349d464b5ab415458a3e557e.zip
Version bumped. Closes #40045.
Diffstat (limited to 'dev-db/libiodbc/libiodbc-3.51.2.ebuild')
-rw-r--r--dev-db/libiodbc/libiodbc-3.51.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-db/libiodbc/libiodbc-3.51.2.ebuild b/dev-db/libiodbc/libiodbc-3.51.2.ebuild
new file mode 100644
index 000000000000..92fd1b03b298
--- /dev/null
+++ b/dev-db/libiodbc/libiodbc-3.51.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.51.2.ebuild,v 1.1 2004/03/04 13:18:59 tantive Exp $
+
+DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.iodbc.org/"
+SRC_URI="http://www.iodbc.org/downloads/iODBC/${P}.tar.gz"
+
+LICENSE="LGPL-2 BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~alpha ~amd64"
+IUSE="gtk"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ gtk? ( >=x11-libs/gtk+-1.2.10* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/libiodbc-3.51.2_install_symlink.diff
+ cd ${S}
+}
+
+src_compile() {
+ local myconf
+ myconf="--with-layout=gentoo"
+
+ if [ "`use gtk`" ]
+ then
+ myconf="$myconf --enable-gui=yes"
+ else
+ myconf="$myconf --disable-gui"
+ fi
+
+ ./configure --host=${CHOST} ${myconf} || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ #dodoc AUTHORS COPYING ChangeLog NEWS README*
+ #find doc/ -name "Makefile*" -exec rm '{}' \;
+ #dohtml doc/*
+ #prepalldocs
+}