summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-14 06:30:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-14 06:30:20 +0000
commit85476860294f8a8a997358596a7098ca9b17c28f (patch)
tree179f7f853553c1b5318e6bbabe2c6efb1899c0c9 /dev-db/mysql-super-smack/files
parentVersion bump per bug #229381. (diff)
downloadgentoo-2-85476860294f8a8a997358596a7098ca9b17c28f.tar.gz
gentoo-2-85476860294f8a8a997358596a7098ca9b17c28f.tar.bz2
gentoo-2-85476860294f8a8a997358596a7098ca9b17c28f.zip
Bug #245090 - fix for GCC4.3. Bug #169538 - avoid binary filename collisions with gen-data, install as super-smack-gen-data instead.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc3-00249-ga622cf6 x86_64)
Diffstat (limited to 'dev-db/mysql-super-smack/files')
-rw-r--r--dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch45
-rw-r--r--dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch9
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch
new file mode 100644
index 000000000000..37abfe35ec97
--- /dev/null
+++ b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch
@@ -0,0 +1,45 @@
+diff -Nuar super-smack-1.3.orig/smacks/select-key.smack super-smack-1.3/smacks/select-key.smack
+--- super-smack-1.3.orig/smacks/select-key.smack 2005-05-30 03:04:38.000000000 -0700
++++ super-smack-1.3/smacks/select-key.smack 2008-11-13 22:27:48.125627179 -0800
+@@ -24,7 +24,7 @@
+ min_rows "90000"; // the table must have at least that many rows
+ data_file "words.dat"; // if the table is empty, load the data from
+ //this file
+- gen_data_file "gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
++ gen_data_file "super-smack-gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
+ // if the file above does not exist, generate it with the above shell command
+ // you can replace this command with anything that prints comma-delimited
+ // data to stdout, just make sure you have the right number of columns
+diff -Nuar super-smack-1.3.orig/smacks/update-select.smack super-smack-1.3/smacks/update-select.smack
+--- super-smack-1.3.orig/smacks/update-select.smack 2005-05-30 03:04:51.000000000 -0700
++++ super-smack-1.3/smacks/update-select.smack 2008-11-13 22:27:45.070167829 -0800
+@@ -24,7 +24,7 @@
+ min_rows "90000"; // the table must have at least that many rows
+ data_file "words.dat"; // if the table is empty, load the data from
+ //this file
+- gen_data_file "gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
++ gen_data_file "super-smack-gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
+ // if the file above does not exist, generate it with the above command
+ }
+
+diff -Nuar super-smack-1.3.orig/src/Makefile.am super-smack-1.3/src/Makefile.am
+--- super-smack-1.3.orig/src/Makefile.am 2001-02-24 03:44:30.000000000 -0800
++++ super-smack-1.3/src/Makefile.am 2008-11-13 22:27:37.693573246 -0800
+@@ -19,7 +19,7 @@
+ INCLUDES = @MYSQL_INCLUDE@ @PGSQL_INCLUDE@ @ORACLE_INCLUDE@
+
+ noinst_PROGRAMS=test-dictionary test-client test_tcp_client
+-bin_PROGRAMS=super-smack gen-data
++bin_PROGRAMS=super-smack super-smack-gen-data
+ test_dictionary_SOURCES=test-dictionary.cc \
+ dictionary.cc dictionary.h \
+ die.cc die.h \
+@@ -57,7 +57,7 @@
+ tcp_client.h tcp_client.cc
+ super_smack_LDADD = @MYSQL_LIB@ @PGSQL_LIB@ @ORACLE_LIB@
+
+-gen_data_SOURCES=gen-data.cc die.cc die.h
++super_smack_gen_data_SOURCES=gen-data.cc die.cc die.h
+
+ # yacc needs to generate a y.tab.h
+ YFLAGS = -d
diff --git a/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch
new file mode 100644
index 000000000000..23bcd56e019c
--- /dev/null
+++ b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch
@@ -0,0 +1,9 @@
+--- src/dictionary.h.orig 2008-10-31 19:12:51.000000000 +0100
++++ src/dictionary.h 2008-10-31 19:13:12.000000000 +0100
+@@ -23,6 +23,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstring>
+ #include <time.h>
+ #include <stdlib.h>