summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-09-23 19:32:44 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-09-23 19:32:44 +0000
commite1d764447c994f8f8ffcda7c92eefad85661e940 (patch)
tree125f9f8e5a146ec17b53e22c80488b50ff7d57bf /dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild
parentMasked eclipse 3.1 M1 and newer (diff)
downloadgentoo-2-e1d764447c994f8f8ffcda7c92eefad85661e940.tar.gz
gentoo-2-e1d764447c994f8f8ffcda7c92eefad85661e940.tar.bz2
gentoo-2-e1d764447c994f8f8ffcda7c92eefad85661e940.zip
Version bump.
Diffstat (limited to 'dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild')
-rw-r--r--dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild b/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild
new file mode 100644
index 000000000000..6b7383367d90
--- /dev/null
+++ b/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/pgaccess-0.99.0.20040219.ebuild,v 1.1 2004/09/23 19:32:44 nakano Exp $
+
+inherit eutils
+
+MY_P=${P//./_}
+
+DESCRIPTION="a database frontend for postgresql"
+HOMEPAGE="http://www.pgaccess.org/"
+SRC_URI="mirror://sourceforge/pgaccess/${MY_P}.tgz"
+LICENSE="POSTGRESQL"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="virtual/libc"
+
+RDEPEND=">=dev-lang/tcl-8.3.4
+ >=dev-lang/tk-8.3.4
+ >=dev-db/postgresql-7.3
+ dev-tcltk/tcllib"
+
+
+src_compile() {
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_install() {
+ make prefix=${D} install || die
+ rm -rf ${D}/usr/lib/pgaccess/win32 \
+ ${D}/usr/lib/pgaccess/Makefile
+ rm -rf ${D}/usr/lib/pgaccess/osx
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/lib/pgaccess/{README,changelog,copyright,demo,doc/html,todo} ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/lib/pgaccess/doc
+}
+
+pkg_postinst() {
+ einfo "When running the program, if you encount the error "
+ einfo "\"Error: Shared library file: '/usr/lib/libpgtcl.so' does not exist.\","
+ einfo "you need to emerge postgresql with USE='tcltk' again"
+}